Software Keyboard not showing up

Issue:
So, whenever i need to type something, instead of showing the Software Keyboard it shows the 3ds onscreen keyboard. At first it looks normal, until you type. https://imgur.com/a/DvQHUHI

This issue didn’t occur yesterday, it only started today.

System Information

  • Operating System: Windows 10
  • CPU: Intel® Core™ i5-3470 CPU @ 3.20GHz (4 CPUs), ~3.6GH
  • GPU: NVIDIA GeForce GTX 760
  • Citra Version (found in title bar): Nightly 1258
  • Game: Any game/software that requires a keyboard.
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
citra_log.txt (418.1 KB)

System Information for Support

Client Version                                Nightly 1258 HEAD-7ea82e7
OpenGL Vendor                                 NVIDIA Corporation
OpenGL Renderer                               GeForce GTX 760/PCIe/SSE2
OpenGL Version                                3.3.0
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             [x]
Enable Shader JIT                             [x]
System Region                                 -1

I did not find anything wrong in your log file. Please wait for a moderator to assist.

I have a somewhat similar issue with Bravely Default when I try to rename the special abilities, but on my end the keyboard doesn’t even show up, Citra either straight up freezes or pops up a dialog box where you can type, but once you press OK/Cancel it freezes the game no matter what.

(Canary v1339 btw)

It also crashes sometimes with tomodachi life. So it’s a gamble whether my game will crash/freeze.

Tried using an older version, same issue occurs. Doesn’t happen on other systems except my main pc.

I made a step by step example with screenshots, to better highlight the issue.
Canary is now v1440 by the way, but the same happens with Nightly v1259.

  • This is Bravely Default, when I click on the Touch Screen on the right to Edit a Special Ability, Citra dialogbox pops up (at this point, I already knew something was up because you can’t even see the “Ok/Confirm” key properly).

At this point then, when you attempt to leave the menu the game freezes, you can hear the music still going on in the background and Citra itself is still responsive (no need to kill the process, you can freely use the menus to Exit Citra) but the game is totally unresponsive and glitched.

For the record, I’m now playing Bravely Second: End Layer and I’m having the same issue as with Bravely Default, with Canary 1359, this time the Citra dialog box doesn’t even pop up tho. :confused:

So finally after it being like, well over two whole years since I encountered this problem, trying literally EVERYTHING, whether it be reinstalling the emulator several times, trying out several different builds, trying out even the most recent update as of right now, trying to search everywhere for a solution or at least some sort of explanation for this problem, and finding just, absolutely nothing except unread forums, I just completely gave up and lost all hope in fixing this for the longest time. However, last night, I picked it up again, and finally decided to try, just, straight up fixing it myself, and it turns out it was a lot easier than I thought. I’m posting this not JUST for OP, but for ANYONE who finds this and still has this problem because for some reason I haven’t seen a single person with a solution to this issue that literally has such a simple fix!!

If you have this problem, it won’t only apply to just one game, it’ll be a universal problem among almost literally EVERY game you emulate on Citra, that, I think, from what I recall correctly utilize the optional dumped user files to function properly. (maybe I could be wrong though) It will literally make all those games almost entirely unplayable.

The cause of this issue is, I’m 99% sure SOMETHING related to file(s) in said user folder, if you’ve dumped yours. I’m not quite sure what files they are IN SPECIFIC, but it makes the most sense that it could be in relation to the shared fonts, maybe? It was technically an update that caused this for me, but only AFTER I had just dumped the user files.
Anyways, I don’t think anyone cares that much about what I think COULD’VE caused it. All that truly matters is that if you’ve dumped your files before and are having this issue only after you dumped them, like me, then hopefully what I did to fix it will help you too.
So here’s what I did:
Reinstalling the emulator by using the uninstaller doesn’t remove all traces of the files, which includes the ones that caused this problem. So in order to completely remove them,

  1. Go to your Start Menu, type “%AppData%”, then open it.
  2. Navigate to the “Roaming” folder.
  3. In the Roaming folder, there should be a folder for Citra. Just delete it.
  4. Go to your control panel. Uninstall Citra through there. (or through Windows settings, It doesn’t matter ig.) It’ll open the Citra uninstaller and, y’know the drill, check off “remove all components” then let it uninstall. Any leftover traces of Citra should be removed in their entirety now.
  5. Install Citra again. I suggest just sticking to the Nightly build and not bothering with Canary to ensure this won’t happen again, like what I did.
    (And ofc just a heads up. You should backup any important files you wanna keep before doing this, obviously, like save files, bios & firmware, roms, etc.)

The virtual keyboard should work fine now.

Check to make sure it works by testing it in-game. If it does, then:

  1. Upon opening Citra Nightly, click “File” then “Open Citra Folder”
    This folder was in AppData/Local instead for me this time around, and had the Citra.EXE file in it, which is really important.
  2. Make sure you re-go through the process of dumping the user files again, at least just to be safe, because I assume that you shouldn’t reuse the old ones that caused this. (If you want, though you can try it. I wouldn’t know. Feel free to tell me if it works or not.)
  3. Place them in the folder that Citra opened for you. Whatever folder has the Citra.EXE file is the one you need to dump them in.

And then it’s done! It worked fine for me after doing that.
I’m sure there are probably other ways to go about this better or something but I wouldn’t know. I just know what worked FOR ME, and that as long as you follow these specific steps, it’ll for sure work, hopefully. Doesn’t hurt to try.

If it doesn’t work, though, feel free to let me know, and I’ll try figuring it out as best I can.
and if there are any other questions you wanna ask me about this, then feel free to do that too.

I hope I helped at all and I hope you all have a nice day!

Did you dump your nand files using TheeSD perchance? Older versions of ThreeSD used to dump the system keyboard applet incorrectly, causing freezing issues when used in-game. This might be related to your issue if so.