[Solved] macOS fatal error when starting any game in nightly 390 or newer

Issue: When I start any game, I get a fatal error.

Steps to reproduce:
• Open Citra on macOS
• Launch any game
• A window pops up stating that Citra encountered a fatal error.

System Information
Device: Macbook Pro 13’’ late 2013

  • Operating System: macOS 10.13.1
  • CPU: Intel i5 2.6 GHz dual core (4th generation)
  • GPU: Intel Iris graphics 5100
  • Citra Version (found in title bar): nightly 390 or newer
  • Game: All games

Terminal log: https://pastebin.com/32tqbYRY

Did you dump the required system archives from your 3DS?

I don’t think this is the reason. I’ve been trying Samus Returns and it runs on the linux builds without a Sys Archive dump. I’m having the same issue on my mac, but instead of the “tainted” messages, I’m getting:

[ 2.212304] Service.FS <Warning> core/file_sys/ncch_container.cpp:OpenFile:107: Failed to open /Users/_____/.local/share/citra-emu/sdmc/Nintendo 3DS/00000000000000000000000000000000/00000000000000000000000000000000/title/0004000e/001bb200/content/00000000.app

I didn’t dump them because the games I have don’t really need them. Besides, I could play just fine using builds older than nightly build 390. The change in that is what created this problem, since it was the first build, using which I get the errors. I tried a lot of builds to find this. If system archives are now mandatory, I’ll dump them and try again.

This issue should be solved now in the latest Nightly release.