[SOLVED] Xbox One S Controller not recognized

Issue:
Just a quick update, I upgrade to Windows 10 now everything is working perfectly.

"I’m new to Citra and have been trying to connect my Xbox One S Controller to it.
However, I can’t seem to enter a key in the “Input” task, I also tried pasting the controls into the “qt-config.ini” which didn’t work either. The controller is connected via BlueTooth and it works just fine in ppsspp, what can I do? "

System Information

  • Operating System: Windows 8.1
  • CPU: Amd Athlon x4 860k Quad-core 3.7ghz
  • GPU:
  • Citra Version (found in title bar): Citra Nightly 954
  • Game: Monster Hunter XX
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

Reset to defaults and try again.

Still not working, I tried both the Nightly and Canary build, sadly with the same results.
Thus, I added a screenshot of my “qt-config.ini", to make it easier to find the cause of my error.

is your controller driver up-to-date?
try these lines:

button_a=“button:1,joystick:0,engine:sdl”
button_b=“button:0,joystick:0,engine:sdl”
button_x=“button:3,joystick:0,engine:sdl”
button_y=“button:2,joystick:0,engine:sdl”
button_up=“hat:0,direction:up,joystick:0,engine:sdl”
button_down=“hat:0,direction:down,joystick:0,engine:sdl”
button_left=“hat:0,direction:left,joystick:0,engine:sdl”
button_right=“hat:0,direction:right,joystick:0,engine:sdl”
button_l=“engine:sdl,button:4,joystick:0”
button_r=“engine:sdl,button:5,joystick:0”
button_start=“engine:sdl,button:7,joystick:0”
button_select=“engine:sdl,button:6,joystick:0”
button_zl=“direction:+,axis:2,engine:sdl,threshold:0.5,joystick:0”
button_zr=“direction:+,axis:5,engine:sdl,threshold:0.5,joystick:0”
button_home=“engine:keyboard,code:66”
circle_pad=“axis_x:0,joystick:0,axis_y:1,engine:sdl”
c_stick=“axis_x:3,joystick:0,axis_y:4,engine:sdl”

According to my Device Manager no updates are available for my Controller, also copying the setting does nothing, Citra automatically resets it’s Controls to the default option if I paste your code in the “qt-config.ini".

Follow this guide to verify that. you can also try to move temporarily the qt-config.ini file to another folder and open citra and try to configure it.
Note: moving this file will reset all citra configurations (you won’t lose any data). you can always move it back.

Thank you for all the support, but I think it is quite impossible for my Controller to connect with Citra, as sadly there aren’t any other options I’m aware of. The guide isn’t helpful either as “The app only works with Windows 10 with the Anniversary update applied”, whilst I have Windows 8.1.

Submit an issue here then (include details, i.e all the specifications and methods that you tried):

Can you try and see if your controller is recognized with http://generalarcade.com/gamepadtool/?

SDL2 is unable to recognize my Bluetooth Controller, same goes with Steam (which I hadn’t tested so far). It appears to only work with PPSSPP.
Meaning that the problem has nothing to do with Citra.

1 Like

I hope it’s not too late to chime in here! I’ve had this issue with several emulators. I can’t get my controller to work via Bluetooth, but it works fine when I plug it into a USB port. If you’re using an Xbox one controller, you should be able to plug it in using a micro usb.

I plugged my xbox 1 controller into my computer via USB and I can’t get it to recognize. Is there something else I need to do to get it recognized? I went to the “Configure” settings in controllers…