Some 3DS games works slow

Hello, I am trying to run some 3DS games in my laptop, some games works normal while some works very slow.

Mario and Sonic Olympic series for example, 2012 London is working great, but 2016 Rio works slow, I want to know why some works slow and how to make 2016 Olympic version as normal.

I parts I have in my laptop are:

-AMD Ryzen 5 2500U Processor

-8GB DDR4 2400 SDRAM

-Microsoft® Windows 10 Home (64 bit)

-AMD Radeon Vega 8 Graphics


In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

Try disabling ‘Enable Hardware Shader’. also you have an AMD GPU which is known to perform poorly because of its less than optimal OpenGL drivers.

amd gpu not working well with citra ̣, some games just don’t want to “use” the gpu and the loading % is very low , that vega 8 run Kirby better than my rx 560 for some reason , some other like Metroid samus return run good and use the gpu as much as it need , maybe try some cheap used gt 1030 or gtx 750 , and wait for future update , I heard that the team are gonna focus on accurate first then performance , maybe ll move on to dx or vulkan later ,hope so:rofl::rofl::rofl::rofl:

I noticed that in Mario Kart 7 with the Ryzen 5 2400U it was not running at full speed on Windows, but running on Linux (Arch, latest mesa drivers, not AMDGPU-PRO) it runs at full speed, and when I uncheck the speed limiter, it runs faster than full speed. Might be worth a shot /s

If you have tried everything related to the graphics, I have found that allowing the citra app to be open, and not running any games for like 15 minutes usually does the trick.