Some Fire Emblem Fates DLC not showing up in game

I’m running into an issue running Fire Emblem Fates (Birthright, specifically) and getting Citra to recognize all of the DLC. The other scenarios (Conquest and Revelation) are showing up, as some of the maps from Map Pack 1 (Ghostly Gold, Boo Camp, Museum Melee, Beach Brawl, Royal Royale, Before Awakening, and Hidden Truths 1+2), but the remainder of maps from Map Pack 1 (Vanguard Dawn, Anna on the Run, Ballistician Blitz, A Gift from Anna, and Witches’ Trial) and all of Map Pack 2 are not being displayed among my installed DLC and are not available to play from the Dragons’ Gate.

On the other hand, if I go to the game’s DLC menu and select the “Download Separately” option, there are a ton of entries just named “Reserved.” I suspect these are the missing DLC, but I’ve no idea how to activate them.

Both the game and the DLC are dumped from my own copy from my 3DS using GodMode9 version 2.1.1. All the DLC shows up as expected when I run the game on my actual 3DS hardware.

System Information

  • Operating System: Windows 11
  • CPU: AMD Ryzen 7 3700X
  • GPU: NVIDIA GeForce RTX 3070
  • Citra Version (found in title bar): Nightly 1779
  • Game: Fire Emblem Fates: Birthright (USA)
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
citra_log.txt (34.1 KB)

Are you sure that you installed your latest game update version? The log file seems to indicate that it isn’t installed. In general, most DLC require some sort of accompanying game update to properly activate, so I would suggest trying to install that: Dumping Updates and DLC

I wasn’t aware Fire Emblem Fates had any updates…? I don’t see anything installed on my 3DS (where all the DLC works as expected) in GodMode9 or FBI, just the base game and DLC. I don’t see any updates listed on 3dsdb.com, either (but I’m not 100% sure I’m looking correctly, to be honest).

I don’t have the game myself, so I can’t check. It is possible that the game shipped with DLC capabilities in mind, though it’s rare. Can you try uploading a log file after installing a DLC? Perhaps something is going wrong there that would point us in the right direction.

Sure. Here are two logs, one from a clean install of Citra running the game before I installed the DLC, and another from that same install where I install the DLC, try running the game again, and get the same problem wherein only certain DLC are showing up.

citra_log.NoDLCInstalled.txt (41.7 KB)

citra_log.DLCInstalled.txt (38.8 KB)

Sorry, maybe I wasn’t clear. I’d like to see a log file of the installation of the DLC. I’m looking for something going wrong during the installation, since the log file with and without the DLC installed don’t tell me much (log files are basically emulation state logs after all).

The second log should be both. It’s the complete log from the Citra session where I both installed the DLC and tested it.

There’s not much there, as best as I can tell, just these lines (but the complete log is there, of course, in case I’m missing anything):

[  32.059510] Service.AM <Info> core/hle/service/am/am.cpp:InstallCIA:333: Installing F:/Games/Emulation/ROMs/Nintendo 3DS/DLC/Fire Emblem Fates (W) (DLC).cia...
[  32.060493] Service.FS <Error> core/file_sys/ticket.cpp:GetTitleKey:50: CommonKey 0 missing
[  32.068091] Service.FS <Error> core/file_sys/ticket.cpp:GetTitleKey:50: CommonKey 0 missing
[  36.651324] Service.AM <Info> core/hle/service/am/am.cpp:InstallCIA:378: Installed F:/Games/Emulation/ROMs/Nintendo 3DS/DLC/Fire Emblem Fates (W) (DLC).cia successfully.

Ah my bad. Totally skipped over those. Anyways, these two lines:

[  32.060493] Service.FS <Error> core/file_sys/ticket.cpp:GetTitleKey:50: CommonKey 0 missing
[  32.068091] Service.FS <Error> core/file_sys/ticket.cpp:GetTitleKey:50: CommonKey 0 missing

Basically tell us that your DLC is encrypted, and you don’t have the keys install. So even though installation action succeeded, nothing got installed since it was encrypted.

If I recall correctly though, I’m relatively sure that the Fire Emblem games have had this issue with supposedly “encrypted” DLC for a while now. There’s a decent chance that you’ve dumped them correctly, but Citra just doesn’t know how to install these DLC. Try using ThreeSD to install both your game and the DLC at the same time. Perhaps then it’ll stick.

That… sort of worked, I guess? It’s definitely progress, at least. I was able to use ThreeSD (which I didn’t even know was a thing before now and am already kind of love with, so thank you for that) to successfully import the DLC into Citra, and the missing “Reserved” DLC are no longer listed under the “Download Separately” menu in the in-game DLC menu.

Initially, though, it looked like the game would freeze with pretty much 100% reliability any time I tried to access the actual in-game list of installed DLC or whenever the game tried to access any DLC in-game for whatever reason. To be clear, the game would freeze: Citra itself seemed fine. The log looked like this when it happened:

citra_log.txt (31.2 KB)

After a few attempts (without doing anything differently), though, I was able to get the DLC to load, but it appears like this in the menu:

The “Reserved” entries, which appear to be the previously missing DLCs, should show the actual names, not “Reserved.” That being said, I was actually able to access the DLC maps and play them in game. I haven’t played any of them to completion, but they seem to work, with the only obvious issue being that they’re not titled correctly in the menus.

I’m going to test it a bit more thoroughly, but assuming it’s actually going to remain stable and not freeze like it was doing and all the DLC is accessible if mislabeled, I’m satisfied with this. Thanks for your help!

I’m glad it works somewhat, even if janky lol

Yea, like I said, this is a longstanding issue with this game. Installing manually never works, so it’s good to know that ThreeSD yields some more positive results.