Some games won't start - Steam Deck

I have three games set up in Yuzu on my Steam Deck: Tears of the Kingdom, Animal Crossing: New Horizons, and Super Mario Bros Wonder. Everything was working fine. I updated Yuzu to 1622 through Emudeck’s Steam ROM Manager today. Now, when I start up either TOTK or ACNH, Yuzu freezes. However, Wonder still works fine. I disabled all mods. Still no go. Any ideas? Thanks!

PS - I’m not sure if I should be asking this here or in the Steam Deck community forum.

In order for us to provide better support, we need to see the log generated by yuzu. This guide will walk you through how you can obtain the log file: Getting Log Files - yuzu

The yuzu update to 1624 appears to have fixed the problem. However, I lost access to my save files and need to start over. Not a huge problem, but a little annoying!

For the saves if you want.
Right click the game in yuzu’s list, select open save data location, navigate two folders back and you will be in the profiles ID folders, check if there is an older profile and the save will be there, copy it back to the current profile and it should work.

That save idea worked, but I’m back to square one. When I update Yuzu to the latest version, everything works. But, when I save my game (TOTK) and then try running the game in Game Mode later, it freezes on the black screen after a second once again. I tried uninstalling and reinstalling Yuzu. No change. I tried deleting my save files. No change. There must be some glitch in how the Steam Deck, Yuzu, EmuDeck and TOTK interrelate. Through it all, Super Mario Wonder works fine. The only other factor I can see is that Wonder is an XCI file and the others are NCP files. But if that was the problem, why did they all work until three days ago?

try reapplying your update&/dlc that might have been some issue with our spaghetti emulated filesystem.

I found a different solution. If I run my Yuzu games through Emulation Station, they all work perfectly. I have no idea why!