Sonic Lost World Throws a Fatal Error at the SEGA Logo

Issue:
Hi there, new Citra user here, just started getting things set up yesterday.

I’ve been able to get some games up and running with no major issues, including the game I’m mentioning here, Sonic Lost World. However, after playing the tutorial level, the game froze up and any time I have tried to run it again, it gives me the usual “This game saves progress automatically” prompt, and then Citra throws a fatal error right after that, when the SEGA logo would usually appear.

I read through other, older support threads that I would/might need certain Mii Data, and I’ve been able to set that up, but even afterwards, I still have the same issue. I even tried deleting the game from the folder I keep my games for Citra in, and put it back, as well as deleting the save data I had for the game, but I still get the error at the same point.

Any tips would be greatly appreciated!

System Information

citra_log.txt (273.2 KB)

System Information for Support

Client Version                                Nightly 1601 HEAD-f72be7a
Operating System                              Windows 10 (10.0)
CPU                                           AMD Ryzen 9 3900X 12-Core Processor            
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             GeForce RTX 2080 SUPER/PCIe/SSE2
GPU Driver Version                            451.67
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.
  • You have cheats enabled. This might cause weird behaviour or crashes. Please disable them and retest if your game is experiencing bugs or crashes.

OK, I’m an idiot. Turns out cheats being enabled was in fact what was causing the error (which I’m making bold in case any other new users encounter a similar issue)

But my problems aren’t solved yet. I’ve tried finishing the tutorial stage a couple of times now, but every time I go to press A to continue after the rank shows up, the game slows to 2% of its speed according to the window, and I just get stuck with a repeating clicking noise. It’s the same freezing up issue I mentioned above, just that now I don’t get an error when I restart the emulation.

Upload a new log (after it slows down) please.

Try reducing the resolution and turn off sound
Then set your speed limit to unthrottled

Setting the speed to unthrottled unfortunately didn’t help, and apparently my log’s file size is too big? (I followed the steps to uploading the log, but it still winds up making a log that’s too big to upload on its own here.)

If it’s too big you can paste the content to like https://pastebin.com/ or zip it and upload to like Google Drive then link it here. Make sure you give public access.

have you tried other games
maybe your rom is corrupted

Hey, sorry for the delay in response.

Here’s a link to my log once the game freezes up: https://pastebin.com/tn74ep0A

At the end there are those two “PANIC” errors, and the reason why the full log was so big is because they just keep repeating over and over after that.

I’m assuming this has to do with corruption at this point, since I haven’t had any similar troubles with other games I’m trying.