"Soul Hackers" slows down when menus appear

Issue:
When trying to play Soul Hackers, whenever a menu is open (when in the main menu or any time during battle, though especially when multiple windows are open), the game might randomly slow down from intervals of 0.5~4 seconds, seemingly without anything prompting it.

This is unique from the other games I tested: Those don’t run perfectly either, but it’s usually momentary hitching while some intense effect is happening or when rendering shaders for the first time. (For reference, I tested Fire Emblem Echoes, which feels like it should be far more intensive but runs far smoother, even when in the 3D battle sequences.) This seemingly happens at random—I left it in idling the same state (i.e. just leaving it on one menu), and it would both work normally and slow down seemingly at random.

System Information

  • Operating System: Windows 11 Home
  • CPU: 12th Gen Intel Core i7-1250U w/ turbo enabled (up to ~3.2ghz)
  • GPU: Intel Iris Xe Graphics
  • Citra Version (found in title bar): Citra Nightly 1824
  • Game: Devil Summoner: Soul Hackers
  • Screenshot of Issue (include the full Citra window including titlebar):



Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt (66.9 KB)

Hmm, this is the first I’ve heard of this issue. Might be related to your hardware’s drivers.

Please go to Emulation>Configuration>System and set the CPU Clock Speed to somewhere around 50%. Then try your game again. If it freezes, set the CPU Clock Speed close and closer to 100% until you get a stable underclock. Let me know if it affects the framerate at all.

Neither updating my drivers nor increasing the underclock seems to make it go away. It’s still pretty random; sometimes I can get through fights without a hitch and sometimes it slows down to %60~70 performance for seconds at a time.

Maybe it’s just an issue with my hardware? I tried some extreme underclocking (~25%), and the slowdowns only really starts to go away once the clock speed is so low the 3DS itself is struggling to reach 60FPS. Maybe it’s just a deceptively taxing visual effect (the transparency effect on menus)?

Hmmm. your hardware shouldn’t be an issue. Are you sure that your laptop is plugged into the charger while you’re using Citra? Some devices have rather aggressive downclocking when on battery to save on battery life. So that might be contributing to the poor performance.

That’s probably not it: I’ve disabled almost every form of downclocking on my laptop to get the processor to run this fast in the first place. I basically keep it plugged in whenever I’m doing anything intensive.

Intel released some new drivers for your GPU. So it would be good to try those as a last ditch effort:

Download and install gfx_win_101.4032.exe from Intel® Arc™ & Iris® Xe Graphics - WHQL - Windows*
Mirror download: https://downloadmirror.intel.com/764788/gfx_win_101.4032.exe