Speed problems(dropped speed and fluctuating between 80 and 50%)

Issue:
Whenever I load up a game the speed seems to fluctuate between 100 And 50. How do I fix it?

System Information

  • Operating System: Windows 10
  • CPU: Intel Core i7(2.50GHz)
  • GPU: Nvidia gtx1060
  • Citra Version (found in title bar): Citra Nightly
  • Game: Pokemon ultra sun
  • Screenshot of Issue (include the full Citra window including titlebar):
  • Log Settings:citra_log.txt (4.0 KB)
    I just want the game to run at 100% without too much drop in speed

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

System Information for Support

Client Version                                Nightly 1387 HEAD-15ed600
OpenGL Vendor                                 NVIDIA Corporation
OpenGL Renderer                               GeForce GTX 1060/PCIe/SSE2
OpenGL Version                                3.3.0
GPU Driver Version                            430.86
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
System Region                                 [x]

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from NVIDIA’s website. https://www.nvidia.com/Download/index.aspx
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

System Information for Support

Client Version                                Nightly 1387 HEAD-15ed600
OpenGL Vendor                                 NVIDIA Corporation
OpenGL Renderer                               GeForce GTX 1060/PCIe/SSE2
OpenGL Version                                3.3.0
GPU Driver Version                            430.86
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
System Region                                 [x]

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from NVIDIA’s website. https://www.nvidia.com/Download/index.aspx
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

System Information for Support

Client Version                                Nightly 1387 HEAD-15ed600
OpenGL Vendor                                 null
OpenGL Renderer                               null
OpenGL Version                                null
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
System Region                                 [x]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Since you are on a laptop double check that Battery Boost in GeForce Experience is turned off(if you have it installed) as well as making sure Power management mode in Nvidia Control Panel is set to Prefer maximum performance.

I had already turned it off and enabled maximum power, it still slows down most the time.

If that was the intro/title screen then it’s pretty normal as it is CPU intensive. Do you have 100% speed in the overworld/battles?

There are some stutters here and there which is also normal because there is no shader cache saved to disk yet.

It’s recommended to take screenshots with Print Screen key on your keyboard(can be abbreviated as Prnt Scrn or Prt Sc) or use like Snipping Tool instead of using a phone camera.

So would that mean there is nothing I can do? If so that’s fine but if there is a setting or something that can make a difference please let me know.

A high clocked CPU can “hide” some of these issues, frametime needs to be <16.67ms to maintain 100% speed. I have noticed on my i7-3770K if I’m normally at like 4-5ms get spikes to like 15ms but still be fine. You are on a laptop though so you have inherently weaker hardware unfortunately.

When shader cache on disk arrives on Canary you can try if it helps with drops during transistions.