Star Fox 64 3D running under 20 FPS on native resolution and settings. Same results on AMD and GeForce GPUs

I just dumped my Star Fox 64 game cart and tried playing it with Citra. Upon loading it, the game runs between 12-17 FPS from the title screen alone. I get a consistent 11 FPS just from setting up my controls under options, which at least loads in a single Arwing. Not long after leaving the options menu, my game has crashed. It also crashed shortly after I tried changing my settings so the game would run better.

I thought this game was supposed to run great on Citra, why am I having issues with it?

P.S. I have another support post that has not gotten a response yet regarding a more specific issue with ORAS. I should also mention that ORAS runs better on my computer than Star Fox 64, despite ORAS being listed as “okay” and Star Fox being listed as “great”. ORAS speed fluctuation in menus

System Information

  • Operating System: Windows 10
  • CPU: Intel Core i5-3470 CPU @ 3.20 GHz (4 CPUs)
  • GPU: AMD Radeon HD 7700 Series
  • Citra Version (found in title bar): Canary 1758
  • Game: Star Fox 64 3D

Diagnostic Log
citra_log.txt (48.4 KB)

Update: Just tried running the game on my dad’s computer, results were only a few FPS higher.

System Information

  • Operating System: Windows 10
  • CPU: Intel Core i5-4690K CPU @ 3.50 GHz (4 CPUs)
  • GPU: GeForce GTX 970
  • Citra Version (found in title bar): Canary 1758
  • Game: Star Fox 64 3D

I’m unable to attach a log for this system because I’m limited to 2 links per post. But I do have it saved if I need to share it.

System Information for Support

Client Version                                Canary 1758 HEAD-9b0a1d1
Operating System                              Windows 10 (10.0)
CPU                                                   Intel(R) Core(TM) i5-3470 CPU @ 3.20GHz
Graphics API                                  OpenGL 3.3.1
Graphics Renderer                             AMD Radeon HD 7700 Series
GPU Driver Version                            20.2.2 26.20.15019.19000
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.

System Information for Support

Client Version                                Canary 1758 HEAD-9b0a1d1
Operating System                              Windows 10 (10.0)
CPU                                                   Intel(R) Core(TM) i5-3470 CPU @ 3.20GHz
Graphics API                                  OpenGL 3.3.1
Graphics Renderer                             AMD Radeon HD 7700 Series
GPU Driver Version                            20.2.2 26.20.15019.19000
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.

System Information for Support

Client Version                                Canary 1758 HEAD-9b0a1d1
Operating System                              Windows 10 (10.0)
CPU                                                   Intel(R) Core(TM) i5-3470 CPU @ 3.20GHz
Graphics API                                  OpenGL 3.3.1
Graphics Renderer                             AMD Radeon HD 7700 Series
GPU Driver Version                            20.2.2 26.20.15019.19000
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.

I barely have full speed on Nvidia however you can try underclocking in Citra to like 50% or so. Drag the CPU slider in the System tab and it should boost performance.

Instant crash on both PCs. Tried playing around with other settings, both below and above 100. Best I got was 23 FPS on my dad’s PC for a few seconds on the title screen before freezing. Here’s the log from my PC trying to load the game at 50% clock speed. citra_log.txt (35.3 KB)

System Information for Support

Client Version                                Canary 1758 HEAD-9b0a1d1
Operating System                              Windows 10 (10.0)
CPU                                                   Intel(R) Core(TM) i5-3470 CPU @ 3.20GHz
Graphics API                                  OpenGL 3.3.1
Graphics Renderer                             AMD Radeon HD 7700 Series
GPU Driver Version                            20.2.2 26.20.15019.19000
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.

I had the same problem. Solution: use an older build like Nightly build 1543 . Star Fox 64 runs super slow with the latest build but runs great for me now with that older build!

Details for the devs in next post.

More details for the devs:
For me Star Fox 64 runs at 100% speed in older builds and 60% speed in newer builds. Immediately after booting (during intro/title screen/main menu) you can tell whether its running slow or not. I had the same problem with it running slow but I saw some youtube videos from 2017 and 2018 where people had this game running full speed so I tried multiple releases and found the following:

Around April 22:
Canary 1688: 100% speed.
Canary 1690: 60% speed.
Around May 11-12:
Nightly 1543: 100% speed.
Nightly 1544: 60% speed.

citra_log-nightly-1543.txt (21.1 KB) citra_log-nightly-1544.txt (24.2 KB)

P.S. Underclocking didnt solve it: I’ve tried underclocking to 80% CPU (it sped up to 70% of game speed) while underclocking to 75% CPU crashed.

P.P.S. This project is awesome! Let me know if I can help in any way like testing things out or something.

Does it crash immediately? I tried various underclocking(75%, 50%, 25%) at the title screen and it was fine there.

Let me check …

Build “Nightly 1554”:
25% crashes during intro (3seconds).
50% crashes immediately,
75% crashes almost immediately,
80% crashes during the intro (5seconds),
90% cpu clock it gets to the title screen, says its running at 60% speed, then wont go past the title screen

Build “Nightly 1543”:
25% cpu works perfectly and runs at 100% speed rock solid 30fps,
50% cpu works perfectly and runs at 100% speed rock solid 30fps,
75% cpu works perfectly and runs at 100% speed rock solid 30fps

Edit: Sorry I was using 1543 not 1553.

Ok, I don’t know if region matters but if it does then I’m using the EU version.

Ok I just tried the european version and unfortunately it behaved exactly the same with build Nightly 1554. So your speed is at 100%?

100% clock speed:


75%:

50%:

25%:

I booted up just fine at 25%, but yeah I’m not actually playing the game so if it freezes later on I wouldn’t know :stuck_out_tongue:

Ok thanks for taking this seriously and testing it out so thoroughly so far. Your test is probably good because the problem is evident by the title screen: either its running too slow to be playable, or it crashes by then and you’re screenshots show that you’re not seeing either of those problems.

  1. What could I and this other guy be doing wrong?
  2. Why did it stop playing smooth at build 1544?

Nightly 1544 is when changes to improve the accuracy of core timing got merged:

But I guess this game is one that got worse performance because of it, another game is like Dragon Quest Monsters Joker 3: Professional where it freezes every few steps.

I guess for now use 1543 until it is fixed. Sorry for the inconvenience.

The problem seems to be the ‘enable new 3ds mode’ checkbox. Turning that off seems to make the game run at 100%. (Update 7/18/2020)

Ok thank you for all of your help @Tywald! Party on!

3 Likes

I’m super late to this, but I just tried this myself and it works. I had to lower my CPU to 50% like Tywald recommended, but it ran smooth enough that I didn’t notice any drops. But there were various graphic bugs that I’ll make another post about.