Star Fox 64 3D - Various Missing Textures

Issue:
In Star Fox 64 3D there are a lot of blacked out textures including the Arwings.

System Information

  • Operating System: Windows 10 Home
  • CPU: Processor Intel(R) Core™ i3-6100U CPU @ 2.30GHz, 2301 Mhz, 2 Core(s), 4 Logical Processor(s)
  • GPU: Adapter Description Intel(R) HD Graphics 520
  • Citra Version (found in title bar): Nightly 1820
  • Game: Star Fox 64 3D
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt (77.3 KB)

System Information for Support

Client Version                               Nightly 1820   HEAD-84eada8
Operating System                             Windows 10 Version 2009
CPU                                          Intel(R) Core(TM) i3-6100U CPU @ 2.30GHz | AVX2 | FMA
Graphics API                                 OpenGL 4.3.0
Graphics Renderer                            Intel(R) HD Graphics 520
GPU Driver Version                           26.20.100.8142
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [x]
Hardware Shader, Accurate Multiplication     [x]
Shader JIT                                   [x]
System Region                                -1
Shader Disk Cache                            [x]

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from Intel’s website. Support for Intel® Graphics
  • The CPU Clock percentage is not 100%. You may experience unexpected game speed.

^ This driver is out of date. To update, download and install gfx_win_101.3790_101.2114.exe from Intel® Graphics – Windows* DCH Drivers
Mirror download: https://downloadmirror.intel.com/751359/gfx_win_101.3790_101.2114.exe

Let me know if you encounter any issues during the installation.

Additionally, you should remove your old shader cache:
Go to File>Open Citra Folder. Then open up the shaders folder and delete the opengl folder found here. Now try your game again.

This is an issue:

Ah, proprietary driver. We can get around that by manually installing a legacy driver first, and then install the latest driver again:

Download win64_25.20.100.6373.zip from https://downloadcenter.intel.com/download/28289/Intel-Graphics-Driver-for-Windows-10
Mirror download: https://downloadmirror.intel.com/28289/a08/win64_25.20.100.6373.zip

Then follow this guide to install it: https://www.howtogeek.com/343287/how-to-fix-the-driver-being-installed-is-not-validated-for-this-computer-on-intel-computers/

Now you should be able to install the latest DCH drivers directly:
Download and install gfx_win_101.3790_101.2114.exe from Intel® Graphics – Windows* DCH Drivers
Mirror download: https://downloadmirror.intel.com/751359/gfx_win_101.3790_101.2114.exe

I installed the older drivers, then the newer drivers like in the guide, but the problem still persists…

It’s for the older drivers where you follow the guide :stuck_out_tongue: the newer is simply running the .exe but verify 6373 is properly installed first before doing it.

You can upload a new log or go to device manager then properties on Intel HD 520 graphics under Display adaptors then it will say on the Driver tab.

The whole point was that I couldn’t upgrade with just the .exe in the first place!

After installing the .zip older driver manually using the guide, you should be able to just use the .exe installer for the latest driver, as I mentioned in my previous post. We only do it manually once to get around the installation restrictions. Once the manual install is done, using the .exe shouldn’t be an issue anymore.

Like tywald said though, if you’re still experiencing the issue, please upload a new log file so we can check what driver you currently have installed.

Here is a new log file:
citra_log.txt (37.8 KB)

System Information for Support

Client Version                               Nightly 1820   HEAD-84eada8
Operating System                             Windows 10 Version 2009
CPU                                          Intel(R) Core(TM) i3-6100U CPU @ 2.30GHz | AVX2 | FMA
Graphics API                                 OpenGL 4.3.0
Graphics Renderer                            Intel(R) HD Graphics 520
GPU Driver Version                           31.0.101.2114
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [x]
Hardware Shader, Accurate Multiplication     [x]
Shader JIT                                   [x]
System Region                                -1
Shader Disk Cache                            [x]

Here’s some issues I found with your log that might help.

  • The CPU Clock percentage is not 100%. You may experience unexpected game speed.

Can you upload an in-game save file (upload it to like Google Drive then link it here) so I can test on my end?

Here try this: 25.95 MB file on MEGA

Also, I can see a blacked out arwing on the title screen.

Oh that is a save state unfortunately.

The save folder looks like this:

These are the save files:

Seems to be fine on Nvidia at least:

Just to be sure, does this also happen if you load your save normally in-game (i.e no save states)?

It always happens regardless of a save or a save-state

Ok, to be sure it’s not a problem with the rom, try redump it so you can test with a clean copy.

I tried with a fresh dump but it didn’t help!

Please upload a new log file.