StarFox missing textures

I went to play starfox today and it had many textures missing, textures that only appear when I disable rendering via hardware, what I don’t understand is what happened from yesterday to today that the game simply stopped working, I already tried uninstalling and reinstalling the emulator, I’ve tested other roons, I believe the problem started when I tried to install a game CIA

System Information

  • Operating System: Windows 10 Pro
  • CPU: Intel(R) Core™ i5-4460S CPU @ 2.90GHz 2.90 GHz
  • GPU: Intel HD Graphics 4600
  • Citra Version (found in title bar): nightly 1835
  • Game: StarFox

citra_log.txt (133.0 KB)

GL_VERSION: 4.3.0 - Build
^ This driver is out of date. To update, download from Intel® Graphics Driver for Windows* [15.40]
Mirror download:

Then follow this guide to install it:

Furthermore, because your iGPU has driver bugs, you’ll need to disable Accurate Multiplication in Emulation>Configuratrion>Graphics>Advanced tab to prevent graphical issues from occurring.

Furthermore, you should disable Dump Textures in Emulation>Configuration>Graphics → This option is only useful for those that are interested in creating their own custom textures.
You may also want to delete all the textures its dumped so far: Go to File>Open Citra Folder, then open up the dump folder and delete the textures folder found here (this will delete all dumped textures for all of your games).

If after this you’re still experiencing the same issue, please upload a new log file.

The same problem continues, I’ve done everything the tutorial said and restarted the pc, I believe I’m performing a little better in terms of FPS, but the texture problem hasn’t gone away
citra_log.txt (192.8 KB)

Go to File>Open Citra Folder, and delete the shaders folder found here. Now try your game again.

If the same issue remains, this is most likely a driver bug, which is very common for your specific integrated GPU. This isn’t something we can do anything about unfortunately.

it didn’t work at first, so I uninstalled and installed the emulator and the room is now working, thank you very much, I love this game.

it worked, but when i closed the game and started again the problem came back, but thanks for the help anyway

apparently, whenever I open pokemon X and walk around the game before entering starfox, does it work? Could it be that in pokemon it creates some shader cache and that’s why my PC is able to render the textures better or something like that, I might be talking nonsense because I’m still a bit of a noob with this

The shader cache is game specific. Shaders created for one game are kept in, and loaded from, a separate folder entirely. So shaders created for Pokemon X shouldn’t affect Starfox’s cache at all.

What you could try to do is disable the Disk Shader Cache to completely rule out the shader cache as an issue (Emulation>Configuration>Graphics>Advanced Tab). If that doesn’t work, go back to that same tab and disable Hardware Shaders (this will slow down the game). That might give us some more insight.

what I don’t understand is why when I open pokemon before opening starfox the game works and when I open starfox directly it doesn’t work, can I send you a video showing in more detail what happens?

Sure, go right ahead.

I sped up the video so it wouldn’t be too long, the video is kind of stuck because there was a lot open.

I attached a link with the video of the problem screen, basically as soon as I ran starfox it had a problem with the texture, so I opened pokemon and played until I left the house, when I opened starfox again it was working

Does repeatedly launching star fox also solve the issue? Or is it only when you launch Pokémon, followed by Starfox?

hello, sorry for the delay I had some problems with my pc and I couldn’t use it for a while, but it’s only when I run pokemon before starfox