Steam Deck: A,B,X,Y buttons no longer responding

I have been playing Animal Crossing: New Leaf on Steam Deck using Citra for a couple of weeks. All had been fine. Yesterday, when I tried playing New Leaf, the ABXY buttons were no longer responsive. I tried different controller layouts. Same issue. I tried a Sony PlayStation wireless controller with Bluetooth. Same issue. The buttons work normally in every other emulator and Steam Deck game/app.

I suspect that the problem is the latest update in Steam OS or in Citra.

System Information

  • Operating System: SteamOS 3.3.3
  • CPU: It’s a Steam deck, so it has the typical Steam Deck CPU and GPU.
  • GPU:
  • Citra Version (found in title bar): Nightly 1821
  • Game: Animal Crossing New Leaf
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

I haven’t been able to get the diagnostic log. There is no separate log window when I follow the instructions!

In order to save a copy of the log, follow this guide:

In order for us to provide better support, we need to see the log generated by citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File

If i minimize the log window, the main Citra window also minimizes. I can’t play Citra without closing the log window. So I can’t get a log!

Reverting to a slightly older version of Citra fixed this issue for me.

In desktop mode, in a console, I ran:

sudo flatpak update --commit=145b5adb7feea971c07a35d1c1e81d8554a0c20ea46b77da23061ef343c450f2 org.citra_emu.citra

This reverts to the version of Citra that was posted on 13 Dec, as can be verified by running:

 flatpak remote-info --log flathub org.citra_emu.citra

Thanks! This fixed my issue, too!