Suddenly loading rom takes too long and crash

Issue:

I enjoyed playing Animal Crossing New Leaf (amiibo), it worked very well, for a while, at least.

However, the game used to crash sometimes so I had to force-restart the game.
Yesterday it happened again, so I restarted Citra, and suddenly the whole computer just stops in the black loading screen. I waited, but nothing happened.

I tried re-installing the emulator and also re-installed cia file, but the problem continues.
Please help…

System Information

  • Operating System: Windows 10
  • CPU: Intel i7-4702MQ
  • GPU: GeForce GT740M (Yes, this is laptop)
  • Citra Version (found in title bar):
  • Game: Animal Crossing New Leaf amiibo
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping. citra_log.txt (17.1 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                                Nightly 1465 HEAD-23921e3
OpenGL Vendor                                 NVIDIA Corporation
OpenGL Renderer                               GeForce GT 740M/PCIe/SSE2
OpenGL Version                                3.3.0
GPU Driver Version                            425.11
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from NVIDIA’s website. https://www.nvidia.com/Download/index.aspx
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

Hi, I’m investigating a bit on this matter but in other games however I haven’t been able to replicate these crashes yet.

Do this to check something for me:

  1. Open Citra then File->Open Citra Folder
  2. Open shaders folder then opengl folder
  3. Screenshot the content in both precompiled and transferable folders so I can see how big the .bin files are in them.

Oh I actually solved this problem by not checking Disk Shader Cache option.
I am pretty sure that the problem happened because the size of the pre-loaded shader cache is too big;

by the way, though I couldn’t give you the screenshot(due to certain problems) but the size of the files:

/precompiled/0004000000000000.bin : 13,328kb
/precompiled/0004000000086500.bin : 6kb
/transferable/0004000000000000.bin : 9,213kb
/transferable/0004000000086500.bin : 4kb

I’m not sure but the problem is about the …0000.bin.

1 Like