Sun/Moon/Ultra Sun/Ultra Moon GPU Shaders Fix


I don’t know about you but I had been having an issue where text boxes and the bottom screen wont correctly load, only the text would (Can be seen in this video here: as well as that during battles the Top screen would appear on the bottom screen. My fix for this problem is to go to Emulation>Configure>Graphics and turn off Accurate Hardware Shader. Now this will impact performance if you’re on Intergrated Graphics (Like I am) So just turn down the upscalling a bit. With this on I had full speed at 3x Native Graphics now with this off it runs at around 80-100% speed depending on the area.

Although My specs are
System: Lenovo Thinkcentre E73
CPU:Intel Core i3-4150
GPU: Intergrated Graphics ~ Intel HD 4400
Ram: 4GB

Well anyway I hope this solves the problem if you yourself had it.


Correction: turn on .


More accurate correction: read the OP’s post one more time.

If you don’t know what the new settings do, my advice would be to stay out of typing.
Since “Accurate Hardware Shader” is by default on, your post doesn’t make any sense (or did OP actually mess up and had it on “Off”?)
Disabling that function may give you an additional speed boost, but it may give you issues in other titles (such as Mario and Luigi Paper Jam, etc.)



How can it decrease performance if it’s disabled? It’s ¿ by default.

Oh sorry. I thought you were contradicting me.


Alright so I failed to mention that Accurate Hardware Shader was on by default for me. But the specific problem I had had was solved by turning it off this but for most games that I tested causes issues (Like M+L Super Star Saga where with Accurate Hardware Shader off sprites dissapeared)
Anyway I made an image with said settings on/off on Ultra Moon.


What on Earth! The Accurate Hardware Shader is causing errors!?!? Please verify on latest Canary, then open an issue in GitHub.


Again, you misunderstood them.

The games have issues if they have Accurate Hardware Shader to off.


See the image, will you?


please help sun and moon crash with this setting on.


Please make a new thread for your issue with the template fully filled in.


I have kept CPU jit, accurate hardware shader on, jit shades on yet I don’t get it why the game every few minutes I can hear the audio but the video just suddenly freezes