Super Mario 3D Land running very slow

For some reason, Super Mario 3D Land is the only game that is running slow, literally in slow motion. I can play Pokemon Ultra Sun, Omega Ruby and Zelda in 100% speed, but not SM3D Land.

Am i doing something wrong or this game isn’t playable?

System Information

  • Operating System: W10

  • CPU: Ryzen 5 2600

  • GPU: RX 580 8GB

  • Citra Version (found in title bar): Canary 1405

  • Game: Super Mario 3D Land

  • Screenshot of Issue (include the full Citra window including titlebar):
    https://i.imgur.com/7ulh6KM.jpgcitra_log.txt (41.5 KB)

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

System Information for Support

Client Version                                Canary 1405 HEAD-d5e23e0
OpenGL Vendor                                 ATI Technologies Inc.
OpenGL Renderer                               Radeon RX 580 Series
OpenGL Version                                3.3.1
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             [ ]
Enable Shader JIT                             [x]
System Region                                 -1

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

Unfortunately Radeon can be up to like ~3x slower than Nvidia for OpenGL applications on Windows.

What are your frametimes in like Ultra Sun? if it’s ~16ms you are barely within 100% speed :stuck_out_tongue: On my end I have ~4ms.

You can try dual boot Ubuntu which have better drivers for AMD GPUs for OpenGL. It’s pretty much that or buy Nvidia :frowning:

Edit*
Looked at your screenshot, pretty strange to see ~9ms but 67% speed.

Well, here a shot of Alpha Saphire. I’m running on 6ms, very playable. I dont have Ultra Sun installed anymore, but it i think it had an even better performance.

But why this is happening only on 3D Land? Even Zelda works fine.

AMD being AMD I think, it’s a pretty common around here :stuck_out_tongue: Ryzen is fine, just not Radeon :confused: but yeah on Linux you should have no issues since the drivers for Radeon there are superior for OpenGL which Citra uses.

I know it’s not an answer you wanted to hear.