System camera (qt) shows black

Issue:
when i choose system camera it shows black in preview screen and green in in game camera

System Information

Diagnostic Log
Upload your log file as an attachment by dragging & dropping. citra_log.txt (101.4 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

I did not find anything wrong in your log file. Please wait for a moderator to assist.

What kind of camera device are you trying to use exactly?

my usb webcam which my pc recognizes as sirius USB2.0 and droid cam (my phone via usb)

IIRC Droid Cam has some issues with Citra. Does your USB webcam work in other programs?

yes it works on bandicam skype and discord

Could you please do the following:

  • Open the log console
  • Do a preview in the Camera tab with your USB Camera
  • Copy the content of the log console to a txt and update it here

Thanks!

i couldnt copy it so here is a screenshot
error6

all right. Thank you. I’ll look into it when I get time, but again, likely that’s an issue of your camera. I’m not sure if we can fix it, but I’ll try.

my friend has a better camera than mine his doesnt work too and i asked this on discord too and someone said it maybe is a bug at qt

That is strange. I have a cheap no-brand web cam from China and it works with Citra.

error7
This Shows On the Debug box when i try to use a camera in-game

That likely isn’t relevant. That looks like a 3DS service error, a webcam that won’t even work in Citra’s interface is much more higher up in the software stack.