Taking an hour to boot story of seasons

Issue:
It takes more or less an hour to boot up story of seasons and my laptop freezes in the meantime. In some cases, laptop completely reboots. Game also occasionally crashes and I have to wait another hour to boot it up again. Have already played the game for more than 100 hours and did not have the issue before.

System Information

  • Operating System: Windows 10 Home 64-bit
  • CPU: Intel® Core™ i5-3230M
  • GPU: Intel® HD Graphics 4000
  • Citra Version (found in title bar): Citra Nightly 1550
  • Game: Story of Seasons
  • Screenshot of Issue (include the full Citra window including titlebar):
    Unable to provide a relevant screenshot as game works fine if it boots up successfully.

Diagnostic Log
citra_log.txt (1.2 MB)

System Information for Support

Client Version                                Nightly 1550 HEAD-028609d
Operating System                              Windows 10 (10.0)
CPU                                                  Intel(R) Core(TM) i5-3230M CPU @ 2.60GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) HD Graphics 4000
GPU Driver Version                            10.18.10.5129
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from Intel’s website. https://downloadcenter.intel.com/product/80939/Graphics-Drivers
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

I have recently updated my GPU drivers. Double checked with the site and confirmed that everything is up to date.

Yeah the bot is dumb when it comes to old GPUs :stuck_out_tongue:

Do this:

  1. File->Open Citra Folder
  2. Open shaders folder then delete the opengl folder if it is there.
  3. Emulation->Configure... then click on Graphics on the left
  4. Click on the Advanced tab and turn on Accurate Multiplication

The Disk Shader Cache currently has a bug when Accurate Multiplication is turned off causing it to load all shaders slowly from zero every time you start the game and makes the precompiled cache extrememly large + the RAM usage skyrockets until you crash.

Worked like a charm. Thank you so much for your time.

1 Like