Terry's Wonderland Save Restoration

Issue:
I had backed up my hard save (not a save state) when I was using an earlier version of Citra (version 1781), and after reinstalling Windows, I have reinstalled Citra to the current version (1807). When I load my save game, it loads up just fine, but when I try to save again in game, I am getting the error, “Failed to save game! Please re-insert game card when power is turned off.” I even tried reinstalling the 1781 version, but still no luck. Same exact thing happens.

The odd thing is I can start a new game with no active save file, and I am able to save the game just fine every single time. It’s only when restoring my save games that this error happens. Any help is appreciated as I would really not like to start over if possible.

System Information

  • Operating System: Windows 10 Pro x64 (21H2)
  • CPU: 11th Gen Intel(R) Core™ i9-11900KF @ 3.50GHz 3.50 GHz
  • GPU: NVIDIA GeForce RTX 3070
  • Citra Version (found in title bar): Nightly 1807
  • Game: Dragon Quest Monsters: Terry’s Wonderland 3D
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

citra_log.txt.txt (22.8 KB)

System Information for Support

Client Version                               Nightly 1807   HEAD-bb05d8c
Operating System                             Windows 10 Version 2009
CPU                                          11th Gen Intel(R) Core(TM) i9-11900KF @ 3.50GHz | AVX512 | FMA
Graphics API                                 OpenGL 4.3.0
Graphics Renderer                            NVIDIA GeForce RTX 3070/PCIe/SSE2
GPU Driver Version                           522.25
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [x]
Hardware Shader, Accurate Multiplication     [x]
Shader JIT                                   [x]
System Region                                -1
Shader Disk Cache                            [x]

Here’s some issues I found with your log that might help.

  • You have cheats enabled. This might cause weird behaviour or crashes. Please disable them and retest if your game is experiencing bugs or crashes.
  • You are using open source system files for Mii data. This will appear as your Mii having broken graphics, but will not affect the stability of the game. In order to resolve this, please refer to our guide on dumping system files. https://citra-emu.org/wiki/dumping-system-archives-and-the-shared-fonts-from-a-3ds-console/

Wow…I feel so foolish. I actually looked into my Citra log and saw the “unreachable” error, and I decided to look if the file was “read only” and sure enough, it was. After unticking the “read only” portion, I am able to save effectively.