Texture issues in ORAS with Hardware Renderer

Some textures appear black or shaded weirdly with hardware renderer on. Doesn’t happen in Ultra SM.

System Information

  • Operating System: Windows 10
  • CPU: AMD A10-7700k
  • GPU: R7 250 2GB
  • Citra Version (found in title bar): Nightly 1294
  • Game: Omega Ruby
  • Screenshot of Issue (include the full Citra window including titlebar): https://imgur.com/a/gy8GbD0
    citra_log.txt (51.9 KB)

System Information for Support

Client Version                                Nightly 1294 HEAD-2f7a10e
OpenGL Vendor                                 ATI Technologies Inc.
OpenGL Renderer                               AMD Radeon R7 Graphics + R7 200 Dual Graphics
OpenGL Version                                3.3.1
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             [x]
Enable Shader JIT                             [x]
System Region                                 -1

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

^ Tried Accurate Multiplication but there’s no effect

Maybe related?

Same solution in there fixed it for me, thank you so much!

(Reverted drivers back to 19.4.3 in case anyone finds this in the future)

How did you revert the drivers? I have an M1 mac, and I’m having the same issues

M1 MacOS devices aren’t supported. That’s why you’re experiencing this issue.