The A button on Pokemon Moon wont work

Issue:
I havent really found an explanation for my issue in the forum when I was looking.
While I was away for a good 30 minutes i left citra running pokemon moon open on my pc, it crashed at some point but i wasnt worried because I had saved before I left.
So I restart and the savefile is there but I cant use the A button anymore? i tried changing the key to different buttons (that were unused in the controls), but I cant choose the file or the other two options (live competition and mystery gift)
I booted up my Pokemon X and the a button works on that one, but it wont work on Pokemon Moon (tried restarting and resetting the controls to default too but nothing)

System Information

  • Operating System:
  • CPU:
  • GPU:
  • Citra Version (found in title bar):
  • Game:
  • Screenshot of Issue (include the full Citra window including titlebar):
    https://i.imgur.com/7p49pHf.png

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:
<citra_log.txt (110.0 KB) >

System Information for Support

Client Version                                Nightly 1390 HEAD-4efb9c6
OpenGL Vendor                                 NVIDIA Corporation
OpenGL Renderer                               GeForce GTX 660M/PCIe/SSE2
OpenGL Version                                3.3.0
GPU Driver Version                            377.19
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
System Region                                 [x]

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from NVIDIA’s website. https://www.nvidia.com/Download/index.aspx
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.