The game is still working but citra shows black screen when i start pokemon

Issue:
citra used to work fine, but when i opened pokemon, it shows the intro but it goes black when trying to play actual game. however the sounds react to my keys which lets me know that the game is running fine. except for the black screen.

System Information

  • Operating System: windows10
  • CPU: intel core i7 7th gen
  • GPU: radeon graphics
  • Citra Version (found in title bar): ctra nightly #783
  • Game: pokemon moon and pokemon sun
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping. citra_log.txt (85 Bytes)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

1 Like

Try turning off “Enable Hardware Shader”

3 Likes

wow thnx it worked! thanks so much man appreciated

1 Like

you are the boss man.
Thanks a lot…
Was struggling for a long time.

1 Like

For whatever weird reason, it doesnt work for me… What should I do?

1 Like

Yea me too pls help someone!

Upload a log file: How to Upload the Log File

2 Likes

It doesn’t work for me too, I’m playing Animal Crossing New Leaf Welcome Amiibo

My log file is too big, so here is the downloadlink:
http://www.mediafire.com/file/lzlwlkexaxpp9am/citra_log.txt/file

2 Likes

citra_log.txt (6.3 KB)

System Information for Support

Client Version                                Nightly 1459 HEAD-d26564d
OpenGL Vendor                                 null
OpenGL Renderer                               null
OpenGL Version                                null
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.
1 Like

Here is my 2th Log file pls check http://www.mediafire.com/file/iy8xjo6kvdziht8/citra_log.txt/file

pls check i need help

Do you have a graphics card in your computer? Since your CPU is i5-7400 you have a desktop computer so I think you have one. Right now it is using your iGPU so if you do have a graphics card make sure your monitor is plugged into it and not the motherboard.

citra_log.txt (95.9 KB)

System Information for Support

Client Version                                Nightly 1565 HEAD-2e24183
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i7-7700HQ CPU @ 2.80GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             GeForce GTX 1050/PCIe/SSE2
GPU Driver Version                            442.19
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

Hi, do this:

  1. Open Citra then go to File->Open Citra Folder
  2. Open shaders folder then delete the opengl folder if it’s there
  3. Emulation->Configure... then click on Graphics on the left
  4. Click on the Advanced tab and turn on Accurate Multiplication

The Disk Shader Cache currently has a bug when Accurate Multiplication is turned off causing it to slowly load all shaders from zero every time you start the game and makes the precompiled cache extrememly large + the RAM usage skyrockets until you crash.

1 Like


Hi, thanks but this didnt work. i still get a black screen when launching pokemon x, as seen in the image. i turned the accurate multilication setting on but hasnt fixed. any ideas? thanks

citra_log.txt (12.5 KB)
here the log if it matters.

System Information for Support

Client Version                                Nightly 1565 HEAD-2e24183
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i7-7700HQ CPU @ 2.80GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) HD Graphics 630
GPU Driver Version                            23.20.16.4973
CPU JIT                                       [x]
Hardware Renderer                             [ ]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [ ]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

never mind that log might be irrelevant, i had enable hardware renderer off.