The game starts well but citra shows black screen when i start Pokemon

Issue
Citra used to work fine when i played Pkmn Y and OR, but when i opened pokemon Sun, it showed the intro and then it went black when trying to play actual game. However, the sound remained and it reacted to my keys, which told me that the game was running “fine”, except for the fact that i couldn´t see anything because of the black screen. I tried to turn off “Enable Hardware Shader” wich worked in part, but then the game slowed down considerably so for me is not a complete solution at all.
I also read another solution in a post similar to mine saying that i should delete a “openg1” folder in the citra folder, but i didn´t do it because i also have files of the Y and OR games there so i thought it could damage my progress. If that´s not the case and this is the actual solution please tell me and i´ll try it.

System Information

Diagnostic Log
citra_log.txt (5.5 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

I did not find anything wrong in your log file. Please wait for a moderator to assist.

It looks like you accidentally reopened Citra before uploading the log. The log gets cleared every time you open Citra. Have the log folder open in the background first before closing Citra then immediately upload a new log.

citra_log.txt (47.6 KB)

Srry hope this is the correct log

System Information for Support

Client Version                                Nightly 1584 HEAD-910cc9e
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i7-6500U CPU @ 2.50GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) HD Graphics 520
GPU Driver Version                            23.20.16.4973
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [ ]

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

I´ve tried enabling Accurate Multiplication but that doesn´t work either

Yeah this looks better. Can you go to Device Manager and check under Display adapters if you have more than Intel HD Graphics?

I only have Intel HD Graphics

Citra issue 3

GPU Driver Version: 23.20.16.4973

This driver is outdated, you need to update.

Download win64_25.20.100.6373.zip from https://downloadcenter.intel.com/es/download/28289/Intel-Graphics-Driver-for-Windows-10
direct link: https://downloadmirror.intel.com/28289/a08/win64_25.20.100.6373.zip

then follow this guide to install it: https://www.howtogeek.com/343287/how-to-fix-the-driver-being-installed-is-not-validated-for-this-computer-on-intel-computers/

After you have installed that download and install igfx_win10_100.8476.exe from: https://downloadcenter.intel.com/es/download/29784/Intel-Graphics-Windows-10-DCH-Drivers?product=88194
direct link: https://downloadmirror.intel.com/29784/a08/igfx_win10_100.8476.exe

Also do this:

  1. Open Citra then go to File->Open Citra Folder
  2. Open shaders folder then delete the opengl folder if it is there.
  3. Emulation->Configure... then click on Graphics on the left
  4. Turn on Disk Shader Cache
  5. Click on the Advanced tab and turn on Accurate Multiplication

The Disk Shader Cache currently has a bug when Accurate Multiplication is turned off causing it to load all shaders slowly from zero every time you start the game and makes the precompiled cache extrememly large + the RAM usage skyrockets until you crash.

1 Like

Ok i´ll do all that, but just to be sure (because i don´t know much about these kind of stuff):
If i delete the “openg1” folder, it won´t affect my other games? Progress and similar i mean…

No, it will only clear the shaders so you can use Disk Shader Cache without crashing as long you also turn on Accurate Multiplication.

1 Like

It worked! Thank you so much, it was very helpful. Now it goes a lot faster, with a little micropause from time to time, but efficient in general so it´s ok.

Again, thanks.

1 Like

It should get a bit better when the cache has been built up more :slight_smile: