The Legend of Zelda: A Link Between Worlds Crashes

Issue: The app crashes the moment I try to use the fire rod

Enter a description of your issue here, in full detail.
Up till now, the game works perfectly, but the moment I need to use the fire rod the app crashes immediately :frowning:
I tried in several places within the game, no difference.

System Information

  • Operating System: Android 13
  • CPU: Qualcomm SM8350 Snapdragon 888 5G
  • GPU: Adreno 660
  • Citra Version: 9e8f4bacd
  • Game: The Legend of Zelda: A Link Between Worlds Crashes
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt (11.4 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

The version number you have listed isn’t a build we support. Please download the latest build from Github instead. Make sure to download the .apk file from the list.
Releases · citra-emu/citra-nightly (github.com)

Hello @Jaffa ,
many thanks for your reply. Please, excuse my stupidity… I hadn’t realized that I was using a (very) older version.
I downloaded the nightly version 2091, but once I open the app, it doesn’t recognize my save files, even though apparently the same save path applies.
Any ideas as to how I can solve this?
(would be a bummer to have to start over, as I have already done some progress on the game).
Again, thank you for your help!
Panos

EDIT: never mind, I found out I had set the app path to a different location! Now it works again! Let’s see if now it works correctly!

Hello again,
I thought better replying here, as to not have a separate topic for the same(-ish) issue.
I installed latest build, and the game is very slow from start only to crash after a few seconds.
System info and game is the same, citra version now is nightly-2098

I am uploading the new logs for you:
citra_log[1].txt (10.0 KB)

Many thanks for your help!

No game was booted in your log. If you are experiencing a crash then do not open citra again until after you posted the log as it gets purged when you reopen citra.
For more information, see How to Upload the Log File

not really true, the game boots, but crashes a few seconds later :frowning:

EDIT: I recorded a video of the crash, but now the logs file is empty(?)

Does it crash after loading a save or somewhere else?

Hello @Majora8120
many thanks for your reply.

The game starts, I choose the save file and a few seconds after gameplay, it crashes.
I recorded a video, but unfortunately I cannot upload it here :frowning:

On top of that, I thought to remove the app, delete all relevant files and folders (yes, stupid me including the save files) and I then re-installed it.
Same behavior…