The Legend of Zelda: Majora's Mask 3D Questions

Hello, first post in here. After doing a search for “Majora’s Mask 3D” here in the forums, I have only found an old topic from February 2017 that was ultimately locked sometime near April.

In there, I’ve seen that some user was experiencing heavy frame-rate drops during cutscenes and boss fights. It’s the exact same for me. So far, the only workaround to this, is to lower the resolution to the 1x native one.

My specs are: i7 3820 @ 3.6GHz CPU, 16GB RAM DDR3, and NVIDIA GeForce GTX 1070.

Here’s a screenshot of my graphics settings: https://gyazo.com/52095a5665961bcc7079e9820bc2014e

Notes: I have tried various internal resolutions, and anything above the Native one (240p) causes major FPS drops in cutscenes/boss rooms. I have also tried turning V-Sync off (made no difference) and also turning Adaptive V-Sync on via the NVIDIA Control Panel.

Am I missing something here or should I just wait for some newer version of Citra that will fix this? I have downloaded Citra for Windows x64 (I’m on Windows 10 Home Edition) just a couple days ago, so I assume I have the latest version.

TL;DR - I’m on a beefy PC and Majora’s Mask has major FPS drops during certain instances. Is the problem on my end or not?

1 Like

No, the problem is not on your end. Citra is currently in early stages of development and isn’t well optimized.

Games usually run less than full-speed even on the best computers.

(also, keep V-Sync off everywhere to keep faster performance, because Citra’s V-Sync function is broken and usually makes a negative impact on FPS)

1 Like

Thanks for the quick reply!

I figured the problem wasn’t really on my end, but I still had to ask.

Well, by turning Citra’s V-Sync off, I have major screen tearing. Do you recommend turning V-Sync on (Adaptive didn’t seem to work, maybe some other V-Sync mode?) via the Control Panel?

I myself don’t experience any screen tearing (I have a 60Hz monitor), so I guess this may be an issue for those who have higher refresh rate monitors.

Try Fast or Adaptive (half refresh rate) (since Majora’s Mask is a 30 FPS game).

i noticed tearing happens if you go to full screen mode

1 Like

My monitor is 60Hz too. I’ve just tried Fast and it has absolutely no difference in performance. All in all, Citra’s V-Sync works better for me, since I have the exact same performance.

Just to help those interested in fixing this: here’s where I’m experiencing slow-downs:

  1. During the intro, up until the point where it starts showing Clock Town, I’m getting around 20FPS.
  2. Inside Clock Town’s Great Fairy “shrine”. Again, around 15-20FPS.
  3. Odolwa’s, Goht’s, Gyorg’s and Twinmold’s arena. 15-20FPS.
  4. Several cutscenes, for example Darmani’s one, right after you play the Song of Healing for him, in order to obtain Goron’s mask.

That’s it so far.

Note: I always play in Full screen mode, using the “Large Screen” Layout setting.

Using an AMD FX-8350 I can confirm that I’ve got the exact same issues.
Needs to be played in Native or will have huge drops; and am having drops in these specific areas.
Goes without saying that OOT 3D runs perfectly for me in upscaled resolutions also at 60fps.

After some experimentation I think I’ve found a good work around for the framerate drops! It’s not perfect but from my experiences so far (playing in the first 3 day cycle) outside of the fairy fountain I’ve had a perfectly stable 30FPS at a high resolution (2000x1200 in my case) and a much less choppy fairy fountain (25-28 FPS).

Here’s what you can do to help the game run better:

  1. [NOT RECOMMENDED - Doing this will remove all warning logs that appear in the separate window to Citra and any issues you’ll come across will be much harder to track since you’ll have no reference to the issue - If you wish to contribute to helping the games development and issue solving then don’t follow this option] Go into the config folder (C:/Users/[your-user-name]/AppData/Roaming/Citra/config) and change (log_filter=:Info) to (log_filter=:Critical). This will tidy up all the warnings the Debug Log prints out in the background and let’s the game run smoother at a higher resolution than the 3DS native.

  2. During intense areas (like the Fairy Fountain, which is the only place I’ve tested this so far), just drop the resolution down to the 3DS native. It’s not that pretty but at least you can enjoy a much smoother experience.

Hope this helps!

Please don’t recommend the first option, because the developers are going to have issues if a person does this and they have a issue to report. There will be no log and the person will have to set it back to Info anyway, or they won’t get support.

That’s exactly what I said in my OP. :slight_smile:

Thanks, though!

Fair enough; obviously it’s if the person playing wants to contribute to the overall issue solving or if they just want higher FPS in the games current state. I’ll made amends to the comment now.