Theatrhythm Final Bar Line - player 2 issue

Theatrhythm Final Bar Line does not seem to be reading the controller for player 2.

Yuzu the emulator itself will detect that there is a second controller just fine, and the controller is enabled properly (light is green in the configuration for both player 1 and player 2), and the controller responds when buttons are pressed.

However, once the game is entered, the controller is not read at all. This issue happens on both Yuzu & Ryujinx with this game. I have tried using the controller for player 2 as player 1 and the controller is read properly. I have tried using the original controller for player 1 (that worked) for player 2 and the game does not read it.

Here is a pastebin link to the logfile: [ 0.096729] Input <Info> input_common\drivers\udp_client.cpp:UDPClient:139: Ud -

(Small side note: sometimes this game gets stuck on the initial loading screen indefinitely, but it seems to happen at random. Closing/reopening will eventually fix it)

I did notice through searching that another user reported having a similar issue, but they said it resolved itself - I have not experienced that resolution: Theatrhythm Final Bar Line - duo - player 2 issue

In order for us to provide better support, we need to see the log generated by yuzu. This guide will walk you through how you can obtain the log file: Getting Log Files - yuzu

the workaround is to first disable controller 2, and after you validate “duo” mode in the game, the prompt will appear and it will work. But if you have the 2nd controller already activated, then it won’t work for some unknown reason.
Hope it help you.