Tomodachi Life causing my entire computer to freeze

Issue:
Since I last updated Citra I’ve been having issues getting it to work. Citra itself opens and runs without issue, but when I try to open a rom (in this case Tomodachi Life), performance immediately suffers: the game never makes it to the menu, all programs slow down or stop responding entirely, and I can’t even move my cursor. I tried opening this rom several times, and the severity of the issue varied every time, but it always occurred. Several times I had to force shutdown my computer and I’m not sure if those logs survived; the log I’m including is from an instance I was able to close without powering off my computer.

citra_log.txt (22.4 KB)

System Information

  • Operating System: Windows 10
  • CPU: Intel Core i5-4210U @ 1.70 GHz 1.70GHz
  • GPU: Intel HD Graphics Family
  • Citra Version (found in title bar): Nightly 1580
  • Game: Tomodachi Life

(Sorry if GPU information is wrong or not specific enough, that is the only device name I could find)

System Information for Support

Client Version                                Nightly 1580 HEAD-c4a4b40
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i5-4210U CPU @ 1.70GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) HD Graphics 4400
GPU Driver Version                            20.19.15.4835
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

GPU Driver Version: Build 20.19.15.4835

This driver is outdated, you need to update.

Download win64_15.40.45.5126.zip from https://downloadcenter.intel.com/download/29474/Intel-Graphics-Driver-for-Windows-15-40-?product=81016
direct link: https://downloadmirror.intel.com/29474/a08/win64_15.40.45.5126.zip

then follow this guide to install it: https://www.howtogeek.com/343287/how-to-fix-the-driver-being-installed-is-not-validated-for-this-computer-on-intel-computers/

Also do this:

  1. Open Citra then go to File->Open Citra Folder
  2. Open shaders folder then delete the opengl folder if it is there.
  3. Emulation->Configure... then click on Graphics on the left
  4. Click on the Advanced tab and turn on Accurate Multiplication

The Disk Shader Cache currently has a bug when Accurate Multiplication is turned off causing it to load all shaders slowly from zero every time you start the game and makes the precompiled cache extrememly large + the RAM usage skyrockets until you crash.

Deleting opengl and turning on accurate multiplication solved the problem, thank you! :slight_smile:

1 Like