Tomodachi life crashes immediately after loading shaders

i booted tomodachi life with citra the other day and this morning and it worked fine, but halfway through the day the game lagged really badly and i was unable to do anything so i force quit. since then, it takes twice as long as before to load in shaders, and it always gets stuck on the last shader and seemingly either crashes after loading it in or while trying to load it in. half of the time i try to open the game it also lags out my whole pc and i have to force restart

windows 10
CPU: AMD Ryzen 3 2300x Quad-Core Processor 3.50 GHz (i am very new to owning a PC so if this isn’t what i was supposed to list i’m sorry lol)
GPU: Radeon RX 570 Series (above statement also applies here)
citra nightly 1623
game: tomodachi life
dunno what to put for the screenshot but:

diagnostic log
citra_log.txt (12.0 KB)

System Information for Support

Client Version                                Nightly 1623 HEAD-a576eb6
Operating System                              Windows 10 (10.0)
CPU                                           AMD Ryzen 3 2300X Quad-Core Processor          
Graphics API                                  OpenGL 3.3.1
Graphics Renderer                             Radeon RX 570 Series
GPU Driver Version                            26.20.12028.2
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

Go to Emulation > Configure... > Graphics > Advanced and enable Accurate Multiplication . Then go to File > Open Citra Folder and delete the shaders folder.

1 Like

worked, thanks so much!