Tomodachi Life lag issue

So I tried getting Tomodachi Life to run in my kinda crappy computer… the only one that could run it. I know the game is supposed to be capped at 30 fps, but no matter what I change, enable or disable, I always end up at 13-15 fps, and its hell to play with. I´ve already changed multiple settings like enabling/disabling v-sync, rendering shadows, overclocking, underclocking, changing the games´ speed. Nothing works for me.

Everything else works its just incredibly slow and I dont like playing that way. Anyone know a way to fix it?

Thanks in advance.

System Information

  • Operating System: Windows 10
  • CPU: AMD E2-6110 APU with AMD Radeon R2 Graphics
  • GPU: 4 CPUs ~1.5GHz
  • Citra Version (found in title bar): Nightly
  • Game: Tomodachi Life
  • Screenshot of Issue (include the full Citra window including titlebar): 12-18fps max, usually stays at 15fps

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt (99.0 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                               Nightly 1772   HEAD-3559332
Operating System                             Windows 10 (10.0)
CPU                                          AMD E2-6110 APU with AMD Radeon R2 Graphics     | AVX
Graphics API                                 OpenGL 3.3.1
Graphics Renderer                            AMD Radeon(TM) R2 Graphics
GPU Driver Version                           20.10.35.02 27.20.1034.6
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [x]
Hardware Shader, Accurate Multiplication     [ ]
Shader JIT                                   [ ]
System Region                                -1
Shader Disk Cache                            [x]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.
  • Please enable the Vsync option if you are experiencing screen tearing.
  • The CPU Clock percentage is not 100%. You may experience unexpected game speed.

Your hardware is way too underpowered to be trying to use Citra with. Citra requires relatively decent single thread performance. If we go by passmark, We require a score of around 1800. Your CPU doesn’t even reach 500. Add to that AMD’s terrible OpenGL drivers, and there’s little chance that you can get workable performance out of your system in Citra. Best chance you have a playable framerate would be to use Linux instead. That would at least alleviate the GPU driver bottleneck. It sadly won’t do anything for that CPU bottleneck though.