Tomodachi Life Miis not working

#1

Issue:
I can load Tomodachi Life fine, everything works as normal, i get the bugs most other people get about lines being skipped, which doesn’t bother me, but the miis on my emulator don’t work. The bodies show as normal and i can edit them, but the faces don’t work properly because they just show up as a skin colored square with a giant NO symbol. I have search up this problem but most people just say it crashes or brings up an error which doesn’t happen to me, i just can’t see the mii faces or edit them right. I tried to use both versions of citra, Nightly and Canary, and neither work and i tried to use the demo files found when i open the game “for the first time” (i haven’t saves once yet because of this bug) But other than this bug, the game works just as normal. So does anyone know how to solve this issue and get the mii faces to work properly.

System Information

  • Operating System: Windows 10
  • CPU: Intel Core i5-6400 2.71 GHz
  • GPU: GTX 1050 2 GB
  • Citra Version (found in title bar): Citra Nightly 1244
  • Game: Tomodachi Life
  • Screenshot of Issue:

Diagnostic Log
citra_log.txt (252.5 KB)

#2

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

#3

System Information for Support

Client Version                                Nightly 1244 HEAD-e9c2b27
OpenGL Vendor                                 NVIDIA Corporation
OpenGL Renderer                               GeForce GTX 1050/PCIe/SSE2
OpenGL Version                                3.3.0
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             [x]
Enable Shader JIT                             [x]
System Region                                 [x]

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.
#4

To make them ‘function properly’ dump your system files. Mii Data is missing, so the open-source replacement made by the dev-team is all it can find. Hence, the graphics looking like a giant ‘No’ sign.

#5

I’m still fairly new to citra and these types of files, so I don’t know what dumping the system files means or how to do it, but i will search it up. Thank you for the help.

#6

same is happening to me…

#7

Please help us two. There’s no problem when i played this before (i was using valentin’s build but it was removed) I JUST WANT THIS TO BE FIXED ASAP.

#8

This is ‘fixed’ by dumping your system files from your 3ds. If this wasn’t happening before, it’s because your build had illegally pirates files distributed with it, and you were in violation of the law.

Dump your system files from your 3ds to solve the problem.

#9

I downloaded the official citra and this just happened yesterday. I don’t have a 3DS to dump files. Is there any fix rather than dumping 3DS files since i don’t have one ?

#10

The only fix is to have the copyrighted mii data files, that are held in the 3ds itself. These can only be obtained by dumping them from a 3ds that you legally own. Expecting anything else is a waste. This is the only option.

#11

No It’s not, Idiot. Stop crying.

#12

Happend to me until my friend gave me his 3ds to dump files to citra, there is tutorial that helps you.
if by any chance you have 3ds to dump it your mii will be normal

#14

Once you have got your system archives dumped and installed as described in the following tutorial, there should be no problem anymore.