Tomodachi Life ""This QR code does not contain a Mii" Problem

Issue:
I have a problem when trying to scan QR Codes in Tomodachi Life. It keeps showing the issue that the QR Code that I scanned doesn’t contain a Mii. I made sure the QR Code was high quality and it came directly from my 3DS. I even installed the AES Keys and the 2 CIA files that the GitHub article shows. Yet it still shows this even after installing the keys. How do I solve this problem?
System Information

  • Operating System: Windows 10
  • CPU: AMD Ryzen 5 3600 6-Core Processor 3.59 GHz
  • GPU: Radeon RX 580 Series
  • Citra Version (found in title bar): 1773
  • Game: Tomodachi Life
  • Screenshot of Issue:

Diagnostic Log
citra_log.txt (584.8 KB)

System Information for Support

Client Version                               Nightly 1773   HEAD-353aaaf
Operating System                             Windows 10 (10.0)
CPU                                          AMD Ryzen 5 3600 6-Core Processor               | AVX2 | FMA
Graphics API                                 OpenGL 3.3.1
Graphics Renderer                            Radeon RX 580 Series
GPU Driver Version                           22.Q2 30.0.21020.2
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [x]
Hardware Shader, Accurate Multiplication     [x]
Shader JIT                                   [x]
System Region                                -1
Shader Disk Cache                            [x]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.

[ 121.608905] Service.APT <Error> core/hle/service/apt/apt.cpp:Unwrap:973: Failed to decrypt data

Make sure that the keys you dumped contain the key for slot0x2DKeyN or for slot0x2DKeyX and slot0x2DKeyY together. These are the ones required for Mii decryption.

How do I see if I have those keys? I kind of just followed the GitHub tutorial so I don’t really know how to check.

Go to File>Open Citra Folder, then open up the sysdata folder and open up the aes_keys.txt file. It should list the keys you’ve dumped.

Alright, I found out the issue. I checked the sysdata folder and found out aes_keys.txt didn’t exist and it was because I didn’t install the right .cia files, but even after installing the right ones, I tried out the new 3ds method and it worked! Sorry for the trouble!

2 Likes

i don’t really understand this, is there a full length tutorial?

There is: AES Keys - Citra