(Ubuntu) Citra Update Causes citra to not open


#1

I been using citra for a few months and today i got a new update for nightly build but it wont let me open the application now…
i did not want to uninstall cause of the games i have but is this my only option?
If anyone knows a way around please tell me…
or should i wait for the next update?

thanks in advance :frowning:


#2

Run it via the terminal, what’s the output?


#4

@flamesage

Yeah… not sure how to run applications via terminal… :sweat:


#5

‘/home/user/.citra/canary/citra-qt’
/home/user/.citra/canary/citra-qt: /usr/lib/x86_64-linux-gnu/libQt5OpenGL.so.5: version Qt_5' not found (required by /home/user/.citra/canary/citra-qt) /home/user/.citra/canary/citra-qt: /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5: versionQt_5’ not found (required by /home/user/.citra/canary/citra-qt)
/home/user/.citra/canary/citra-qt: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version Qt_5.9' not found (required by /home/user/.citra/canary/citra-qt) /home/user/.citra/canary/citra-qt: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: versionQt_5’ not found (required by /home/user/.citra/canary/citra-qt)
/home/user/.citra/canary/citra-qt: /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5: version `Qt_5’ not found (required by /home/user/.citra/canary/citra-qt)

This is what happens for me since the updates 2 days ago, older version still starts fine.


#6

We recently upgraded our minimum dependencies for Linux. Which version of Ubuntu are you using?


#7

Linux mint 18 which uses ubuntu 16.04
libqt5 is version 5.5.1

oh I see "/usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version Qt_5.9’ not found "
so would downloading 5.10 from the qt website work?


#8

@flamesage don’t know who you are talking too but if you want mine…

Ubuntu 16.04 LTS


#9

I’m having a similar issue, the main difference is that I am running Debian 9 Stretch. I am missing the same dependencies. Its very weird as when I use the Retro Arch core it actually runs the .3ds games

here is my code

[email protected]:~/.citra/nightly$ ./citra
./citra: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version CXXABI_1.3.11' not found (required by ./citra) [email protected]:~/.citra/nightly$ ./citra-qt ./citra-qt: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: versionQt_5.9’ not found (required by ./citra-qt)
./citra-qt: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.11’ not found (required by ./citra-qt)
[email protected]:~/.citra/nightly$


#10

We upgraded our build system to Ubuntu 18.04, you may have out of date packages in 16.04.


#11

yeah I don’t know where you got Ubuntu 18.04 from but all I can find was Ubuntu 17.10. but if you could tell me where to get it that would be much appreciated


#12

Iirc it’s an LTS Release. See this

Im not very sure where you can get that, since I don’t use Linux, but I guess this might be helpful coz it turned up on top of the Google results.
http://cdimage.ubuntu.com/daily-live/current/HEADER.html

For more on this issue, see


#13

Hey to anyone here i have found my fix to the problem…

my system was outdated for it but i did not get 18.04 I tried 17.10 and it seems to open the application fine. I thank all of you for your help. :3


#14

That’s strange. You are on the same build, right?
Did you update any of the packages Citra was complaining about?


#15

But this only solves the Ubuntu builds. Not debian builds, i have tried to update everything. If some one can show me where the latest build of the dependaces are for debian. I would greatly appreciate that

I still get
[email protected]:~/.citra/nightly$ ./citra
./citra: /lib/x86_64-linux-gnu/libm.so.6: version GLIBC_2.27' not found (required by ./citra) ./citra: /lib/x86_64-linux-gnu/libc.so.6: versionGLIBC_2.25’ not found (required by ./citra)
./citra: /lib/x86_64-linux-gnu/libc.so.6: version GLIBC_2.26' not found (required by ./citra) ./citra: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: versionCXXABI_1.3.11’ not found (required by ./citra)


#16

Citra requires GLIBC_2.27, which may not be packaged yet for your distribution.


#17

After i made my post, there are actually .deb build for all the missing dependencys in stretch but its in buster and sid. Stupidly I force installed the required version but it broke about all of the other dependences for the GNOME UI. Can you create a shortcut on the Downloads page for the Debian OS’s to the last known stable build? At least unitl the other packed are moved to the stable release

As of writing, im backing up personal data and will to a clean install for my system


#18

Hi, I have the same problem (I am using Ubuntu 16.04).

I cannot update anymore citra on my linux distribution. Is there any way to avoid installing a new distribution to be able again to use the latest citra build? Maybe citra could use a flatpak approach (https://flatpak.org/) or simular to distribute linux versions of citra in future?

I think that it is understandable that upgrading/re-installing a new OS is not a painless procedure, and many people cannot allow that due to other incompatibilities that could be arise in other applications. I was baffled In particular since the updated distribution needed to run citra (Ubuntu 18.04) was not even yet stable at the time of the switch :confused:

Thank you for all your work!


#19

Try building Citra from source with these instructions.


#20

Whats Poppin, I am back again with the same problem as before but now on the Ubuntu 17.10 build. Honestly thought i had gotten pass the problem weeks ago but it came back with a vengeance and one point i even considered Virtual Boxing Windows to my computer but the was a vain effort and now i am back… my computer sadly wont give me an update Ubuntu 18 so i am not sure what to do at this point

PS
back when i had 16.04 tried your link already(6-7 times) and when I got to the run citra step it said
“bash: ./src/citra_qt/citra-qt: No such file or directory”


#21

Thank you, it has worked!

By the way the version I compiled following these instructions is the canary-build?