Ultra moon screen goes black when i enable 'enable hardware shader'

#1

Issue:
Enter a description of your issue here, in full detail.
When i play ultra moon the game is fairly slow and runs at 19 fps in the outside environment, but runs at around 27 fps inside buildings. What i have noticed is that when i turn on ‘Enable Hardware Shader’ and enter the game, everything is fine, until i select my profile, then the screen goes black, but the game is still playable and is running at 30 fps and at 100% speed. I am hoping that someone could help me

System Information

  • Operating System: windows 10
  • CPU: intel core i3-7100 2.40GHz
  • GPU: intel hd graphics 620
  • Citra Version (found in title bar): Citra canary #766
  • Game: Pokemon ultra moon
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt (30.9 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

#3

I did not find anything wrong in your log file. Please wait for a moderator to assist.

#4

That is a known issue currently, reduce internal resolution for better performance.

#5

i have the resolution at 2x native, but even though i change it to native, i still have the same problem.

#6

what i meant is that enabling ‘Enable Hardware Shader’ will cause issues regardless, however you can try to reduce internal resolution to increase framerate.

#7

Hm, can you do a test with these two builds?


Does 860 enables you to see anything with Hardware Shader on? And does it break on 861?

#8

I tried, but unfortunately both 860 and 861 showed me the black screen when i chose my profile.

#9

[ 20.281466] Render.OpenGL video_core/renderer_opengl/renderer_opengl.cpp:Init:520: GL_VERSION: 3.3.0 - Build 23.20.16.4973

Your GPU drivers are outdated. Try updating them by downloading the driver from here, and turning on hardware shaders after that.

#10

well…I updated my drivers and it still happens, i think it might be a bug, but hey your the expert and i would love to hear your opinion about this.

#11

also i noticed that if during my gameplay i turn the shaders on, the game will be butter smooth, but if i enter a building or a battle the black screen comes back on.

#12

This is likely an issue with Intel graphics drivers in general that you can’t do much about.

1 Like