Ultra Sun keeps Crashing

Issue:
Enter a description of your issue here, in full detail.
The game keeps crashing as I’m about to talk to Kukui or after I already started

System Information

  • Operating System: macOS High Sierra 10.13.6

  • CPU: 1,4 GHz Intel Core i5

  • GPU: 1,4 GHz Intel Core i5

  • Citra Version (found in title bar): 1763

  • Game: Pokemon Ultra Sun

  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt (42.6 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                               Nightly 1763   HEAD-856b3d6
Operating System                             macOS High Sierra (10.13)
CPU                                          Intel(R) Core(TM) i5-4260U CPU @ 1.40GHz | AVX2 | FMA
Graphics API                                 OpenGL 4.1
Graphics Renderer                            Intel HD Graphics 5000 OpenGL Engine
GPU Driver Version                           ?
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [x]
Hardware Shader, Accurate Multiplication     [x]
Shader JIT                                   [x]
System Region                                -1
Shader Disk Cache                            [ ]

I did not find anything wrong in your log file. Please wait for a human moderator to assist.

Go to Citra>Preferences>Graphics>Advanced Tab and disable Hardware Shaders. Now try again.

It didn’t crash but now I’m getting 14-18 FPS. It even hits 12 FPS in cutscenes. It only hits 30 sometimes when not a lot of things are moving… Is there a way to keep it at 30 FPS like before?

citra_log.txt (87.1 KB)

System Information for Support

Client Version                               Nightly 1763   HEAD-856b3d6
Operating System                             macOS High Sierra (10.13)
CPU                                          Intel(R) Core(TM) i5-4260U CPU @ 1.40GHz | AVX2 | FMA
Graphics API                                 OpenGL 4.1
Graphics Renderer                            Intel HD Graphics 5000 OpenGL Engine
GPU Driver Version                           ?
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [ ]
Hardware Shader, Accurate Multiplication     [ ]
Shader JIT                                   [x]
System Region                                -1
Shader Disk Cache                            [ ]

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

System Information for Support

Client Version                               Nightly 1763   HEAD-856b3d6
Operating System                             macOS High Sierra (10.13)
CPU                                          Intel(R) Core(TM) i5-4260U CPU @ 1.40GHz | AVX2 | FMA
Graphics API                                 OpenGL 4.1
Graphics Renderer                            Intel HD Graphics 5000 OpenGL Engine
GPU Driver Version                           ?
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [ ]
Hardware Shader, Accurate Multiplication     [ ]
Shader JIT                                   [x]
System Region                                -1
Shader Disk Cache                            [ ]

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

It didn’t crash but now I’m getting 14-18 FPS. It even hits 12 FPS in cutscenes. It only hits 30 sometimes when not a lot of things are moving… Is there a way to keep it at 30 FPS like before?

If anyone runs into this, I kept “Enable Hardware Render” enabled but disabled “Enable Hardware Shader” and the game runs smoothly!