Ultra Sun/Moon trading not working

Issue:
I am trying to trade with myself on the pokemon ultra games. I downloaded the correct citra (advised by someone from support). I added the user folder to it and made a copy of it so it’s two seperate emulators. When I make a room and join it with the other account nothings wrong, I invite one of the accounts, I accept and it starts loading. Then however the screen turns black on both of the games and a few seconds later the one that I invited has a screen again. Then when I try to trade, one of the accouns doesn’t show up even though they are both in the same room.

System Information

  • Operating System: Windows 10 Home 64-bit
  • CPU: Intel Core i5-4440
  • GPU: NVIDIA GeForce GT 635
  • Citra Version (found in title bar): Citra Canary 1631
  • Game: Pokémon Ultra Sun/Moon
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

US: citra_log.txt (295.0 KB)

UM: citra_log.txt (906.5 KB)

System Information for Support

Client Version                                Canary 1631 HEAD-6a3afe4
OpenGL Vendor                                 NVIDIA Corporation
OpenGL Renderer                               GeForce GT 635/PCIe/SSE2
OpenGL Version                                3.3.0
GPU Driver Version                            390.77
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from NVIDIA’s website. https://www.nvidia.com/Download/index.aspx
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

System Information for Support

Client Version                                Canary 1631 HEAD-6a3afe4
OpenGL Vendor                                 NVIDIA Corporation
OpenGL Renderer                               GeForce GT 635/PCIe/SSE2
OpenGL Version                                3.3.0
GPU Driver Version                            390.77
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from NVIDIA’s website. https://www.nvidia.com/Download/index.aspx
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.