Ultra Sun running at only 5%

Issue:
Hi, pls bear with me 'cause its my first time running any emulator on a pc :(( I encountered this problem right away during selecting language

and I found a post here from someone who had a similar problem & said it got fixed just by disabling hardware renderer at the advanced graphics settings, so I did just that too. But when I relaunched Ultra Sun, the graphics did get fixed but I noticed it was going really really slow and when I looked at the bottom part of citra it said:

Speed:5%/100% Game:2 FPS Frame:340.44 ms

one problem led to another & it just got me frustrated, sorry, its just that I’m very new to this. Anyway, I was wondering what do I need to configure in the settings to make Ultra Sun run normally?

System Information

  • Operating System: Windows 10
  • CPU: Intel® Core™ i5-3570 CPU @ 3.4 GHz
  • GPU: Geforce GT 730
  • Citra Version (found in title bar): Citra Nightly 1598
  • Game: Pokemon Ultra Sun
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

citra_log.txt (4.5 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

1 Like

Make sure you enable V-Sync in ( Emulation > Configuration > Graphics > Advanced > Enable VSync )

and ( Emulation > Configuration > Audio > Emulation: HLE fast )

Switching from HLE fast can really ruin games being playable, V-Sync should help keep it under control just in case. hope it works!

1 Like

You most likely have old drivers and you should update them:
https://www.nvidia.com/Download/driverResults.aspx/162105/en-us

You might need to check “clean install” in the installer when you pick custom install.

Re-enable Hardware Renderer, you will need it in order to get playable speeds.

1 Like

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Forgot to include the log last night, sorry, but its edited now

Hi, I found that my Citra already had the settings you’ve mentioned but it was still running slow. I also tried updating and now I’m on Citra 1599 but it’s still slow with Hardware renderer disabled

Hi!! So I did update my drivers and re-enabled hardware renderer and it works great now :)) Thanks a lot!

1 Like