Ultra Sun won't launch when Pokemon X will?

Issue: Pokemon Ultra Sun isn’t working.
Enter a description of your issue here, in full detail.
Pokemon Ultra Sun has worked for a few weeks and what I assume happened after an update, it won’t launch. It initially didn’t launch when I tried to launch it after telling me it wasn’t responding. I deleted the Open GL Shader Cache and now it loads the shaders before it says a fatal error occurred and it tells me to not continue emulating.

System Information

  • Operating System: Windows
  • CPU:
  • GPU:
  • Citra Version (found in title bar): Citra Nightly
  • Game: Pokemon Ultra Sun
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt (15.4 KB)

In order to save a copy of the log, follow this guide:

[ 4.856347] Service.FS <Info> core/file_sys/archive_selfncch.cpp:OpenRomFS:192: Unable to read RomFS
Seems like your ROM got corrupted at some point. It’s rare, but it can happen, even if you don’t do anything with it. You’ll need to redump it. Please refer to our game dumping guides:

Dumping Game Cartridges
Dumping Installed Titles

Make sure your GM9 is up to date and that you have enough free storage space available on your SD-Card to perform the dump.