Unable to open Citra with Mac "no such file or directory"


#1

Issue:

I just downloaded Citra last night and got Pokemon Moon to work with some lag. When i closed the application and tried to open it again I couldn’t get it to open. It loads for a while with a few lines of “no such file or directory” then it just shoots a seemingly infinite strings all ending in “File name too long”. I have tried uninstalling and installing other Citra such as Nightly Build - ad4097e but is having the same issue. Below was just a short list of log because it seemed to just keep showing logs ending in “File name too long”.

System Information

  • Operating System: MacOS Sierra
  • CPU: Intel Core i7
  • GPU: Intel Iris Pro
  • Citra Version (found in titlebar): Nightly Build - 5e334af
  • Game:

Log:
[ 0.000000] Common.Filesystem common/file_util.cpp:CreateFullPath:200: path exists /Users/kevinliang/.config/citra-emu/qt-config.ini
[ 28.772148] Common.Filesystem common/file_util.cpp:IsDirectory:122: stat failed on ./Downloads/Mailbox (Beta).app/Contents/Frameworks/Sparkle.framework/Resources/fr_CA.lproj: No such file or directory
[ 28.875905] Common.Filesystem common/file_util.cpp:IsDirectory:122: stat failed on ./Downloads/Mailbox (Beta).app/Contents/Frameworks/Sparkle.framework/Versions/A/Resources/fr_CA.lproj: No such file or directory
[ 28.879983] Common.Filesystem common/file_util.cpp:IsDirectory:122: stat failed on ./Downloads/Mailbox (Beta).app/Contents/Frameworks/Sparkle.framework/Versions/Current/Resources/fr_CA.lproj: No such file or directory
[ 81.070796] Common.Filesystem common/file_util.cpp:IsDirectory:122: stat failed on ./Library/Application Support/Google/Chrome/RunningChromeVersion: No such file or directory
[ 81.090487] Common.Filesystem common/file_util.cpp:IsDirectory:122: stat failed on ./Library/Application Support/Google/Chrome/SingletonCookie: No such file or directory
[ 81.090511] Common.Filesystem common/file_util.cpp:IsDirectory:122: stat failed on ./Library/Application Support/Google/Chrome/SingletonLock: No such file or directory
[ 99.279323] Common.Filesystem common/file_util.cpp:IsDirectory:122: stat failed on ./Library/Application Support/Steam/Steam.AppBundle/Steam/Contents/Frameworks/HTML5App.app/Contents/Frameworks/HTML5App.app/Contents/Frameworks/HTML5App.app/Contents/Frameworks/HTML5App.app/Contents/Frameworks/HTML5App.app/Contents/Frameworks/HTML5App.app/Contents/Frameworks/HTML5App.app/Contents/Frameworks/HTML5App.app/Contents/Frameworks/HTML5App.app/Contents/Frameworks/HTML5App.app/Contents/Frameworks/HTML5App.app/Contents/Frameworks/HTML5App.app/Contents/Frameworks/HTML5App.app/Contents/Frameworks/HTML5App.app/Contents/Frameworks/HTML5App.app/Contents/Frameworks/HTML5App.app/Contents/Frameworks/HTML5App.app/Contents/Frameworks/HTML5App.app/Contents/Frameworks/HTML5App.app/Contents/Frameworks/HTML5App.app/Contents/Frameworks/HTML5App.app/Contents/Frameworks/HTML5App.app/Contents/Frameworks/HTML5App.app/Contents/Frameworks/HTML5App.app/Contents/Frameworks/HTML5App.app/Contents/Frameworks/Breakpad.framework/Versions/Current/Resources/crash_report_sender.app/Contents/Resources/English.lproj/Localizable.strings: File name too long
[ 99.288961] Common.Filesystem common/file_util.cpp:IsDirectory:122: stat failed on ./Library/Application Support/Steam/Steam.AppBundle/Steam/Contents/Frameworks/HTML5App.app/Contents/Frameworks/HTML5App.app/Contents/Frameworks/HTML5App.app/Contents/Frameworks/HTML5App.app/Contents/Frameworks/HTML5App.app/Contents/Frameworks/HTML5App.app/Contents/Frameworks/HTML5App.app/Contents/Frameworks/HTML5App.app/Contents/Frameworks/HTML5App.app/Contents/Frameworks/HTML5App.app/Contents/Frameworks/HTML5App.app/Contents/Frameworks/HTML5App.app/Contents/Frameworks/HTML5App.app/Contents/Frameworks/HTML5App.app/Contents/Frameworks/HTML5App.app/Contents/Frameworks/HTML5App.app/Contents/Frameworks/HTML5App.app/Contents/Frameworks/HTML5App.app/Contents/Frameworks/HTML5App.app/Contents/Frameworks/HTML5App.app/Contents/Frameworks/HTML5App.app/Contents/Frameworks/HTML5App.app/Contents/Frameworks/HTML5App.app/Contents/Frameworks/HTML5App.app/Contents/Frameworks/HTML5App.app/Contents/Frameworks/Chromium Embedded Framework.framework/Resources/crash_report_sender.app/Contents/Resources/English.lproj/Localizable.strings: File name too long


#2

Same here… Did you find the solution?


#3

Is this the full log?


#4

you have the game directory set to the root folder and recursive scan folders on. so citra is trying to check every last file on your computer for games and due to an issue with how i wrote the code, it wont load until it checks every directory. the solution is to manually change the settings file in ~/.local/citra/config/qt-config.ini and either change your game folder or turn off recursive scan


#5

How would i go about doing that? Is there a step by step to doing what you described? I’m not that amazing with these stuff, thanks!


#6

I was hoping someone else would do a write up while i was gone playing breath of the wild, but looks like no one did lol.

Um there really isn’t any step by step guides, and i doubt that i can make the instructions any clearer but i’ll try …

  1. click “Go” then “Go to folder…” and put in ~/.config/citra-emu/config/
  2. open up qt-config.ini
  3. edit the line with Paths\gameListDeepScan=true and change it to Paths\gameListDeepScan=false

then citra should start loading again. from there you can change the game folder to point to where you keep your games. after you change the game folder you can then turn back on gamedir_deepscan in the options by checking the “Search sub-directories for games” option in the config dialog

(its kinda my fault this broke… i plan to fix it soon but this is the first time someone has ever had that combination of settings so it was lower priority)

Edit: thanks klaus for the correct paths. (I was just guessing since i wrote this at work while on break)


Problems on Mac
#7

Thank you very much! :slight_smile:


#8

On my mac i can’t find the folder named citra in my .local, what should i do?

Edit:
I found the config file in ~/.config/citra-emu/
Also the line is called ‘Paths\gameListDeepScan=true’