Unable to play Isle of armor

Here is my issue although the game is updated to v.1.2.0 still I am not getting the armor pass after the launch of my game
Also I used Prometheus sometime but then I got to know that that the one I used is not legal so I am currently using yuzu mainline build 287.
Pokémon sword update 1.1.1 worked fine but when I update it to1.2.0 neither armor pass pops up and also my slowpoke from v.1.1.1 goes missing(only its name remains, the sprite is gone).
If anyone knows the solution please help me!
Note: Also I used a save editor once and I have also used another save file once!


yuzu_log.txt (122.1 KB)

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

System Information for Support

Client Version                                yuzu 287             . HEAD-mainline-636-2279-g4a06e2b3e
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i3-8130U CPU @ 2.20GHz
Graphics API                                  Vulkan 1.2.133
Graphics Renderer                             Radeon(TM) 540 Graphics
GPU Driver Version                            AMD proprietary driver 2.0.137
Docked Mode                                   [x]
Use Async GPU                                 [x]
BCAT Backend                                  none
GPU Emulation Accuracy Level                  Normal

I did not find anything wrong in your log file. Please wait for a moderator to assist.

We got reports of problems when using save editors after the DLC went live.
Make sure you also remove any mod you have.

System Information for Support

Client Version                                yuzu 287             . HEAD-mainline-636-2279-g4a06e2b3e
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i3-8130U CPU @ 2.20GHz
Graphics API                                  Vulkan 1.2.133
Graphics Renderer                             Radeon(TM) 540 Graphics
GPU Driver Version                            AMD proprietary driver 2.0.137
Docked Mode                                   [x]
Use Async GPU                                 [x]
BCAT Backend                                  none
GPU Emulation Accuracy Level                  Normal

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Could you explain what are mods because I taught it was just the patches added to the game but does it also include savefile editing?

Mods would be things like higher resolution modifications, or higher framerate, or the new texture pack. Modifications on top of the game files. Those modifications trigger a bug in the emulator, leading to weird problems happening.
The problem with save editors is unknown, but most likely what happens is that those editors don’t consider the changes the DLC adds, leading to “corrupt” saves.

Yes I checked it I have not used a single mod. I have only used 2patches let’s go Pikachu v.1.0.2 and sword v.1.1.1 & both of them works fine. and my save file is a proper one that I played through the entire game of pokemon sword. After update1.2.0 my game is booting and running properly as before except the fact that Dlc is not at all working. Do you know any reason that why this happens because I have already deleted my register folder and reset my meta cache 40-50 times and tried reinstalling the emulator to. Evenn played with new save file that I began from scratch but still Dlc do not work as if no changes were made to base game and also all my changes from v.1.1.1 (even the slowpoke) from the event is gone.

I got the solution on my own.
All you have to do is uninstall Yuzu file and reinstall it and then overwrite the base game with new update that’s all.
This worked for me at least.
Thanks for you help!

1 Like