Unexpected poor dedicated GPU performance on Linux

Issue:
The performance is way below expected with a 1660Ti, game playable on my internal GPU.
I run the game throught PRIME. Installed the last drivers and followed directions from the official arch wiki to install nvidia drivers.
Now I know in some cases the integrated GPU can give better performances than dedicated but this is really a huge cap regarding the power of a 1660Ti on a emulator like this.
In any case this is an issue and my laptop heat up a lot while running citra on the CPU.

This is not the case on Windows.
I tried Ubuntu but I can’t get PRIME to work properly so I can’t give results using dedicated on Ubuntu

System Information
It’s a Asus Zephyrus GA502DU laptop

  • Operating System: Archlinux on Linux 5.6.15
  • CPU: AMD Ryzen 7 3750H
  • GPU: NVIDIA GeForce GTX 1660Ti Mobile with Max-Q design
  • Citra Version (found in title bar): Nightly 1554
  • Game: Monster Hunter Generations
  • Screenshot of Issue (I don’t have any title bar so I screenshoted the about window):
    with nvidia dedicated : https://i.imgur.com/KI1n4ep.jpg
    with amd integrated : https://i.imgur.com/z4LlvoC.jpg
    (60fps hack shoudn’t be a problem here)

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

Diagnostic Log
with nvidia dedicated : https://gist.github.com/edricus/03994df63c956ec4752fcdada27cb1a3
with amd integrated : https://gist.github.com/edricus/18a1c135c55d05763d99b3f4c50a2235

I have the same problem but in my case both of the GPUs are from AMD. Vega 8 for integrated and Radeon 540x for dedicated

Please start your own topic post and upload a log file.