Unresolvable "Unable to connect to the host." issues

Issue:
I am completely unable to open my citra-room server to connections from the internet. I’ve read at least most of the previous topics on this issue, and I think I’ve followed every single possible step.

I’ve opened ICMPv4 in the Windows Firewall, as well as all of the Citra executables just in case.
I’ve temporarily disabled the IPv4 and IPv6 firewalls on my router, and restarted it.
I’ve forwarded port 24872 to my computer.

CanYouSeeMe(dot)org can not see me, I can’t connect through the Public Room Browser, I can’t connect through Direct Connect using my external IP.

I can connect through Direct Connect using either my internal IP address or localhost (127.0.0.1).

Here’s an album of screenshots of everything.

I’ve tried it with a password, without a password, using the script to launch citra-room, creating a room within citra-qt, using Canary, using Nightly, everything I could think of.

System Information

  • Operating System: Microsoft Windows 10 Pro
  • CPU: Intel Core i5-4690K
  • GPU: NVIDIA GeForce GTX 970
  • Citra Version (found in title bar): Citra Canary 2038 (and Nightly)

In order for us to provide better support, we need to see the log generated by citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File

Here’s my log from Citra when I try to connect to the server, and also the citra-room log where I’m getting a brand new error message that only pops up when I run citra-room Canary, but not Nightly.

[ 330.698257] WebService <Error> web_service/web_backend.cpp:GenericRequest:82: https://api.citra-emu.org

citra_log.txt (6.9 KB)
citra-room.log.txt (2.9 KB)

No game was booted in your log. If you are experiencing a crash then do not open citra again until after you posted the log as it gets purged when you reopen citra.
For more information, see How to Upload the Log File

I assure you, robot, the issue is not with a specific game.

We had some backend updates recently. The dev working on this said that relaunching the room should fix the issue. Can you see if this is still a problem?