Updated to yuzu version 958 from 950 and SSBU lags randomly using vulkan

Hello, as topic says updating Yuzu mainline version 958 from 950 introduced a lag/fps drop that occurs at random when playing a match, normally the second/third match will have this issue, in version 950 I play tested up to 10 matches and nothing happened. Video here.
yuzu_log.txt (2.6 MB)

Here is a list of things that I tried to fix it :

  • Reinstalled/updated drivers to 511.79.
  • Clean reinstall of yuzu and required components. Cleaning vulkan cache.
  • Pagefile increased from 7.5 gb. to 20 gb.
  • Verify there’s no spike in ram or cpu usage when the slow down happens. Also no high temps readings in any of my pc components either.
  • Disable geforce experience and verified no other overlay was active when playing.
  • Set yuzu’s priority to high in task manager.
  • Clean reinstall of Windows 21H2 with all the updates available.

Besides going back to 950, nothing else worked.
Can someone help me solve this issue?

System Information for Support

Client Version                               yuzu 958
Operating System                             Windows 10 Version 2009
CPU                                          Intel(R) Core(TM) i7-4790K CPU @ 4.00GHz | AVX2 | FMA
Graphics API                                 Vulkan 1.3.194
Graphics Renderer                            NVIDIA GeForce GTX 1060 6GB
GPU Driver Version                           NVIDIA 511.79.0.0
CPU Accuracy                                 Auto
GPU Accuracy                                 Normal
Docked Mode                                  [x]
CPU Multicore                                [x]
Async GPU                                    [x]
Async Shaders                                [ ]

I did not find anything wrong in your log file. Please wait for a human moderator to assist.

Thanks for the report, nagging some devs.

Sorry, I can’t reproduce here.
Can you test each mainline version and find the exact one that started the issue?
Releases · yuzu-emu/yuzu-mainline · GitHub get them from there, download the .7z and unpack anywhere.

Sorry I was going to reply earlier with my testing results but then I remembered setting my page file back to 7.5gb and had to redo all over again with 20gb page file.

Yuzu mainline version 951: Wiped my vulkan cache files and tested 9 rounds in total, 4 first to compile shaders and 5 more after a restart and no issue appeared while playing.
Yuzu mainline version 952: 3rd round had slow down just as the video I posted originally.
yuzu_log.txt.old.txt (3.6 MB)
Closed yuzu and tried again: 3rd round had slow down once again.
yuzu_log.txt (3.6 MB)

The testings I did using 7.5gb. showed the same results:
Version 951: 8 rounds no issue.
Version 952: first round had slow down. Restarted yuzu, tested again and 3rd round had slow down.

Something introduced in 952 should be causing this issue for me, considering 950/951 do emulate the game very well.

System Information for Support

Client Version                               yuzu 952
Operating System                             Windows 10 Version 2009
CPU                                          Intel(R) Core(TM) i7-4790K CPU @ 4.00GHz | AVX2 | FMA
Graphics API                                 Vulkan 1.3.194
Graphics Renderer                            NVIDIA GeForce GTX 1060 6GB
GPU Driver Version                           NVIDIA 511.79.0.0
CPU Accuracy                                 Auto
GPU Accuracy                                 Normal
Docked Mode                                  [x]
CPU Multicore                                [x]
Async GPU                                    [x]
Async Shaders                                [ ]

I did not find anything wrong in your log file. Please wait for a human moderator to assist.

Try versions past 960, should be fixed now.