Using Mesa3D for Citra Nightly 1841 on Windows 10

Issue:
I’m trying to use the Mesa3D drivers for Citra Nightly 1841 on Windows 10. Whenever I set them up for Citra, however, I get the error about the OpenGL version not being high enough.This prevents me from being able to run any games using the drivers.

I have tried using both the mingw and the msvc releases of the files.

Is it still possible to use them with Citra?

System Information

  • Operating System: Windows 10
  • CPU: Ryzen 5 3600
  • GPU: AMD Radeon 5600 XT
  • Citra Version (found in title bar): Nightly 1841
  • Game: Any

Diagnostic Log
Not entirely sure the log would be useful here, as it’s not an issue with the game itself. I can obtain one if folks think it would be helpful!

In order for us to provide better support, we need to see the log generated by citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File

You might be able to check what is supported with OpenGL Extensions Viewer: http://www.realtech-vr.com/glview/download.html
Click on the first GLview OpenGL at the top of the page to download.

Latest official drivers: 23.2.1 should provide the more optimized OpenGL drivers: https://www.amd.com/en/support/graphics/amd-radeon-5600-series/amd-radeon-rx-5600-series/amd-radeon-rx-5600-xt

I’ll have to give the 23.2.1 drivers a shot to see if they improve things!

That said, the 22.11.2 drivers that I’ve been using do support running Citra. It’s only when I attempt to run Mesa3D as an “in-between” to convert the OpenGL calls into native Vulkan calls that I start running into the OpenGL issue. I’d seen some sources online showing pretty significant improvements in framerate using Mesa3D, which is why I wanted to get it working. For example: Better Citra performance for AMD GPUs on Windows using zink! - YouTube

This was a thing before 22.7.1 drivers (first version with OpenGL optimizations). Afaik it’s obsolete to use this method now. Older Citra versions targeted OpenGL 3.3 so maybe that is why it worked back then.

Ahh, I see what you’re saying now. Okay, gotcha! Thanks for the info. :slight_smile: