Video Core Error, please help

Issue:
I wanted to play some Pokemon Alpha Sapphire, but I got a message saying something about a video core. I’m not all that techy, so I have no idea what it even means. Some help would be greatly appreciated.

System Information

  • Operating System: Windows 7 Home Premium
  • CPU: AMD Turion™ II Dual-Core Mobile M520 2.30 GHz
  • GPU: AMD M880G with ATI Mobility Radeon HD 4200
  • Citra Version (found in title bar): Citra Nightly / HEAD-189bd79
  • Game: Pokemon Alpha Sapphire
  • Screenshot of Issue (include the full Citra window including titlebar):

Log:
[ 0.000000] Frontend citra_qt/main.cpp:CheckForUpdates:414: Update check started
[ 1.605132] Frontend citra_qt/main.cpp:OnUpdateFound:427: No updates found
[ 6.265644] Frontend citra_qt/main.cpp:BootGame:554: Citra starting…
[ 6.505860] Render.OpenGL video_core/renderer_opengl/renderer_opengl.cpp:Init:488: GL_VERSION: 2.1.8796
[ 6.505926] Render.OpenGL video_core/renderer_opengl/renderer_opengl.cpp:Init:489: GL_VENDOR: ATI Technologies Inc.
[ 6.505955] Render.OpenGL video_core/renderer_opengl/renderer_opengl.cpp:Init:490: GL_RENDERER: AMD M880G with ATI Mobility Radeon HD 4200
[ 6.506011] Render video_core/video_core.cpp:Init:35: initialization failed !
[ 6.506041] Core core/core.cpp:Load:106: Failed to initialize system (Error 9)!

Your GPU is too old for Citra. Citra requires OpenGL 3.3, while you only have 2.1.
Unfortunately, you will need to get a new GPU (or in your case, a new laptop).

Seriously? I just got this for Christmas a month ago.
I’m a bit upset by this, but thanks a lot.

Hello Katie, you can also try searching for updates, if available, for your graphic card and install them. Should solve.

Driver updates won’t solve this. The GL version is hardcoded in the GPU. You can’t upgrade it.

Useful to know that.