Video does not scale to window

#1

Issue:
Due to known issues with recent builds of Citra in Mac OS High Sierra, I tried to run Citra from the terminal to avoid the QT launcher. However, the game displayed in the bottom quarter of the window, scaled to half size vertically and horizontally. Clicking on the bottom half of the window shows that mouse input is still mapped to the full size window. (So clicking at {x,y} in the window causes a button displayed at {x/2,y/2} to activate.)

System Information

  • Operating System: Mac OS 10.13.4
  • CPU: 3.1 GHz Intel Core i5
  • GPU: Intel Iris Plus Graphics 650 1536 MB
  • Citra Version (found in title bar): Nightly 1268
  • Game: Pokemon X
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
citra_log.txt (6.1 KB)

#2

System Information for Support

Client Version                                Nightly 1268 HEAD-af197c1
OpenGL Vendor                                 null
OpenGL Renderer                               null
OpenGL Version                                null
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [ ]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             [x]
Enable Shader JIT                             [x]
System Region                                 -1

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.
#3

Open the ‘sdl2-config.ini’ file located on ~/.config/citra-emu/ and change the ‘resolution_factor’ to resolution_factor = 1 and check if the issue persists. if that works, also try other values like 2 and 3.

#4

Thank you for the quick response.

I tried a range of values, I could not see a difference between any of them, except when I tried 100, which caused the screen to go black.

I also tried a custom layout, which affected proportions, but not the overall size.

The terminal also prints the following error every second or so.

[ 108.339880] Service <Error> core/hle/service/service.cpp:ReportUnimplementedFunction:166: unknown / unimplemented function ‘SetProbeResponseParam’: port=‘nwm::UDS’ cmd_buf={[0]=0x210080, [1]=0x321f00, [2]=0x40000}

[ 109.865084] Service <Error> core/hle/service/service.cpp:ReportUnimplementedFunction:166: unknown / unimplemented function ‘SetProbeResponseParam’: port=‘nwm::UDS’ cmd_buf={[0]=0x210080, [1]=0x321f00, [2]=0x40000}

#5

maximum value is 10 (not sure if higher values do anything). those error messages are irrelevant to your issue, this is likely an issue on mac only, submit your issue here: