Vsync activation

Issue:
Enter a description of your issue here, in full detail.
Well, Im starting to play The Legend of Zelda Ocarina of Time, and every thing is great…but the fact that the game is tearing all the time really boders me :c So, this situation makes me ask.
How can I turn on Vsync? ;-;

System Information

  • Operating System:
  • CPU:
  • GPU:
  • Citra Version (found in title bar):
  • Game:
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

There is no v-sync option currently

Oh, that`s really sad D:
thank u anyway :b

You can turn on vsync but not using the GUI.

Open file %APPDATA%\Roaming\Citra\config\qt-config.ini

Look for section [Renderer], delete line vsync_enabled\default=true and change line vsync_enabled=false to vsync_enabled=true

WARNING: vsync is broken for many people. Framerate drops considerably. It’s not because you have a crappy graphic card, mine is fine. It’s not because your CPU is slow, check task manager and you will see it below 50%. It’s something Citra is doing.

Tip: For some reason that I cannot explain, if you have a NVidia GPU, when you enable vsync you eliminate screen tearing but framerate drops as expected. But… if you use NVidia control panel to override application settings, and select performance or performance/quality, Citra suddenly is super fast, and you can have vsync and a tearing free experience.

I don’t know why, but if you select “let application decide” in NVidia control panel, Citra is super slow. But if you override application settings, Citra works fine, and with vsync. Tearing was making me crazy.

Note that you need to do three things, for NVidia. Use qt-config.ini to eliminate the default line and change to true the other line, and finally set to Performance or Performance/Quality in NVidia control panel. Or you eliminate tearing but have unacceptable performance. And the last doesn’t do anything with tearing, just improves performance.