Vulkan failed to create logical device

This just started after my launch today to latest EA. I was playing on vulkan just fine a few days ago. Now I can only play with opengl.

[ 7.436548] Render.Vulkan video_core\renderer_vulkan\vk_device.cpp:Create:325: Failed to create logical device
[ 7.438850] Core core\core.cpp:Load:199: Failed to initialize system (Error 5)!

yuzu_log.txt (24.4 KB)

System Information for Support

Client Version                                yuzu Early Access 496 HEAD-2ff4117a5
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i7-9750H CPU @ 2.60GHz
Graphics API                                  OpenGL ?
Graphics Renderer                             ?
Docked Mode                                   [x]
Use Async GPU                                 [x]
BCAT Backend                                  boxcat
GPU Emulation Accuracy Level                  Normal

Here’s some issues I found with your log that might help.

  • You have Boxcat (BCAT) enabled. Some games might not work when this is enabled. Please disable and try again if you are experiencing issues with games.

Disabled bcat. (i’ve never enabled it so not sure how it was enabled) but this is every single game. Vulkan engine won’t work. No difference after disabling bcat

I have a Geforce RTX 2070 with MaxQ Design, the device shows up in the select box still when vulkan is selected in the settings.

Nvidia Driver 445.87 latest

Also update the Intel GPU driver.

1 Like

interesting. I have the latest version of the drivers razer provides for my laptop. going to intel’s website warns not to use their generic drivers because they are for “testing” and to stick with the oem drivers. are they lying?

downloading them now. i don’t use the onboard gpu anyhow so worth a shot

That may have done the trick. although i’m not certain because also it downloaded build 500 of EAP so it could have been something fixed in the new version also. But it is working now!

I spoke too soon. it’s back. i switched back to opengl cause vulkan was crashing on a game… then went back to vulkan for another game and now i can’t use vulkan with the same error.

i closed yuzu reopened and now vulkan works again. It would seem there’s a bug when switching from opengl then back perhaps.

But at least it goes away now after a restart (before it wouldn’t)

I recommend a full program close before switching the API.
Regarding crashes in vulkan, try with async GPU disabled, currently vulkan is not stable with it.