Walking and Camera the same?

So I was trying Majora’s Mask 3D and had the usual config, to make use of the build-in function to use a controller via the qt-config.

All the buttons worked correctly but as soon as I got in-game, the up and down controls for the camera were the same as the forward and backward walking controls.
So I would pull the camera down while walking forward and pull it up when I was going back.
I’m working with a ps3 controller via scp and it works for pretty much everything except this.

How exactly do I fix this issue?

Please post the nightly build, OS and controller configuration you’re using.

Nightly build: 84c344b
OS: Windows 10 (64bit)
Controller Config:

[Controls]
button_a="engine:sdl,joystick:0,button:1"
button_b="engine:sdl,joystick:0,button:0"
button_x="engine:sdl,joystick:0,button:3"
button_y="engine:sdl,joystick:0,button:2"
button_up="engine:sdl,joystick:0,hat:0,direction:up"
button_down="engine:sdl,joystick:0,hat:0,direction:down"
button_left="engine:sdl,joystick:0,hat:0,direction:left"
button_right="engine:sdl,joystick:0,hat:0,direction:right"
button_l="engine:sdl,joystick:0,button:4"
button_r="engine:sdl,joystick:0,button:5"
button_start="engine:sdl,joystick:0,button:7"
button_select="engine:sdl,joystick:0,button:6"
button_zl="engine:keyboard,code:49"
button_zr="engine:keyboard,code:50"
button_home="engine:keyboard,code:66"
circle_pad="axis_x:0,engine:sdl,joystick:0,axis_y:1"
c_stick=“axis_x:3,engine:sdl,joystick:0,axis_y:4”

And as mentioned before I use scp to connect my PS3 controller to my pc. It works with every game and on every emulator except this one.