Weird audio issue


#1

I’m currently encountering an issue. I came back to Citra with the new Hardware Renderer Update
and i’m having a blast, speed is always 100% at 8x Native. But my issue is with the audio of these two games
(i can test more games if you think that would help). At start, everything is fine, but after playing for ~30 minutes, sound begins to “crackle” or “glitch”, don’t know how to call it. It’s like the emulator was not keeping up the speed, but it still shows 100%/30 FPS. The audio gets more and more glitchy for like 5 minutes, then it all go back to normal. Approximately 30 minutes later, it does it again and keeps doing it as long as i play.
I’ve used Citra some time ago (before the big update) and it worked flawlessly and without audio issues.
I’ve tried disabling audio stretching, playing at lower res but it doesn’t change anything.
What else do you suggest me to do ?

System Information

  • Operating System: Windows 10
  • CPU: Intel Core i5-4590 @ 3.30GHz
  • GPU: ZOTAC GeForce GTX 970 AMP! Extreme Core Edition 4 GB
  • Citra Version (found in title bar): Citra Canary | HEAD-155bb24
  • Game: Dragon Quest VII ; Terry’s Wonderland 3D

Thanks for your time.

PS: Sorry for my english, not native speaker.


#2

idk but maybe it’s the enable audio stretch thing, if it is enabled try disabling.


#3

Already tried it :frowning:
It was the first thing i disabled actually.


#4

Log please. And can you test on some other games?


#5

Okay, so i’ve tested Pokémon Moon and The Legend of Zelda: Ocarina of Time 3D and both games had the issue. And for the log file, i’ve waited the 5 minutes of the glitch then closed Citra, cause it keeps getting worse over time before stopping.
Anyway here is the log file (playing Dragon Quest VII): https://pastebin.com/a9NXLGx1


#6

Having a very similar issue on canary builds with Monster Hunter XX. Game stays at 100% at all times, yet whenever the music is playing the sound gets so unbelievably crackly it actually makes the game unplayable since it causes ear pain. What’s interesting is it that it doesn’t happen on every citra launch, but about 9 times out of 10 it’s going to do it either immediately or after about 3 minutes of gameplay, and gets worse and worse as time goes on.


#7

Does disabling /enabling Audio Stretching in Emulation - Configure - Audio change anything?


#8

Does this occur on Nightly too? If yes, can you try bisecting? If no, can you disable all the new GPU features and check? That’ll really help us with pinpointing the issue.


#9

I just tested it, my issue also occurs on the latest Nightly Build. And if bisecting means what i think it means (thanks Google), the last 100% functional build was when i played Ocarina of Time and is probably a year and a half old. I can try other builds if you want me to, but i don’t know which ones.

And for the Audio Stretching setting, it doesn’t change anything, enabled or disabled.


#10

you probably tried already but does the Sound output mode change anything?


#11

I’ve tried Stereo and no, it doesn’t make a difference.


#12

Can you give the version number of the newest build which works fine?


#13

Where do i start ? Do i have to test every build from 1 year and a half ago up to now ? That’s gonna take ages, especially since the issue happens only after 30 minutes.


#14


Follow this.


#15

Okay, that’s taking me way too much time, more than 30 minutes per build (and who knows if it could take longer for the issue to happen on older builds). So i’m not certain about those but well:

Canary-270 has the issue
It seems that Canary-241 doesn’t

Again, all this testing is taking me more time than i already have so that’s all i got, sorry.


#16

Can anyone else continue bisecting? If it can be narrowed down to one or two builds, I might try to trace the broken commit.


#18

I heard the citra does that when there is a cut scene or when it needs to load a lot. I like citra but with other emulators (Dolphin, DeSmume) that was better because they took over the sound 1 to 1 LG:EvilDevil


#19

I have the same problem on Ocarina of time 3d on the most recent build of Citra


#20

Okay so coming back to this thread because… well my issue also happens on PPSSPP in the same way: after a while (30 minutes - 1 hour) sound start to “crackle” and back to normal 5 minutes later. I know these are Citra Forums, but i was wondering if you guys had any idea of what could cause my issue. I assume it’s something to do with my computer rather than with emulators. I did change my headset recently (and never encountered this issue before), maybe that’s the cause, but i have no idea how to fix it.


#21

you better off asking for help on a more appropriate forum if your problem is hardware/software.
btw windows has some options to change the way your sound driver behaves (or any software that comes with the driver)