Weird keyboard language thing

I noticed that when the keyboard is on a language other than English (Greek, in my case), Citra won’t respond for some reason when I’m pushing the buttons. Switch back to English, and suddenly it’s fine. Did anyone else notice this?

Can you show with some screenshots where this is happening?

Impossible, because it’s not something that shows up on screen. I turn on the emulator, chose the game, and everything runs smoothly. Everything I do with the mouse works fine. However, when the language is Greek (as opposed to English), then if I try to use the keyboard, then there won’t be a response. It’s like I’m pressing nothing or tapping at the wrong place. Switch the language to English, and problem solved.

I mean on what screen does it happen on, like does it happen on this?

image

Do you mean when you are binding the buttons on the controls screen?

I told you before, there’s absolutely no visual indication. The only way I could show you was if I sent you a video of myself on the laptop, which I’d rather avoid doing. I guess maybe it’s the second? The controls I’m using are the default ones, which are in English.

Let’s put it this way. I’m turning on the game. The language on my laptop is currently Greek. I press the “B” button (S on the keyboard) to skip the cutscene, nothing happens. Cutscene ends, and then I’m on the opening menu. I try to press the A button to load my save file. Nothing happens. I do that with my mouse instead. Game asks me to choose a save file. I try to press A to chose it. Nothing happens.

I switch the language to English. Now I press A again. It works fine.

I simply asked where it happens. It is possible to show that, I gave two examples in my last post where the keyboard might not work in Greek for you. Seeing how you described it, you just meant they don’t work in-game.

I installed Greek in Windows and picked Greek keyboard and I had the same issue (default keys not working) but rebinding them worked. On my end, for some reason both S and W results in Σ so there was a conflict when I wanted to rebind button R. In notepad, W is ΅ so I don’t know why Citra picks up W as Σ instead. You can bind it to E instead or something.

The reason why the default doesn’t work is because Greek uses different codes, see below (this is from the config file qt-config.ini).

English keyboard: A key
profiles\1\button_a="code:65,engine:keyboard"

Greek keyboard: A key
profiles\1\button_a="code:913,engine:keyboard"

So the A key on a Greek keyboard sends the code 913 while it is 65 on an English keyboard.

Oh, that. W is “s final” (ς), which is an s that specifically goes at the end of words. When writing, if you accidentally use the normal σ at the end of a sentence, it’ll be autocorrected to ς (w) even if there’s no an autocorrection program on. I don’t think this can be changed in any way.

Guess I’ll just turn the keyboard to English then. Thank you for answering.

1 Like